A instância do Servidor de Conexão que tem o cartão inteligente conectado não pode executar a verificação de revogação de certificado no certificado TLS do servidor, a menos que você tenha configurado a verificação de revogação de certificado de cartão inteligente.

Problema

A verificação de revogação de certificado poderá falhar se sua organização usar um servidor proxy para acesso à Internet ou se uma instância do Servidor de Conexão não puder alcançar os servidores que fornecem verificação de revogação devido a firewalls ou outros controles.

Importante: Certifique-se de que o arquivo CRL esteja atualizado.

Causa

VMware Horizon é compatível com a verificação de revogação de certificado com listas de certificados revogados (CRLs) e com o Protocolo de Status de Certificado Online (OCSP). Uma CRL é uma lista de certificados revogados publicada pela CA (Autoridade de Certificação) que emitiu os certificados. OCSP é um protocolo de validação de certificado usado para obter o status de revogação de um certificado X.509. A autoridade de certificação deve estar acessível a partir do host do Servidor de Conexão. Esse problema só pode ocorrer se você tiver configurado a verificação de revogação de certificados de cartão inteligente. Consulte Usando a verificação de revogação de certificado de cartão inteligente.

Solução

  1. Crie seu próprio procedimento (manual) para baixar uma CRL atualizada do site da CA que você usa para um caminho no servidor VMware Horizon.
  2. Crie ou edite o arquivo locked.properties na pasta de configuração do gateway TLS/SSL no host do Servidor de Conexão.
    Por exemplo: install_directory\VMware\}\VMware View\}\Server\SSLgateway\conf\locked.properties
  3. Adicione as propriedades enableRevocationChecking e crlLocation no arquivo locked.properties ao caminho local para onde a CRL está armazenada.
  4. Reinicie o serviço do Servidor de Conexão para que suas alterações entrem em vigor.