Uma exceção ocorre durante a sincronização de recursos Citrix com o Workspace ONE Access devido a um erro comum na configuração do Integration Broker, em que a configuração de Identidade foi definida para o pool de aplicativos errado.

Problema

Durante a sincronização, ocorre a seguinte exceção no log do Integration Broker.

Erro do IntegrationBrokerLogger 1002 2017-04-04 19:10:38,936 (16) HznXenIntegrationBroker.ApplicationException.ServiceErrorHandler - Falha na conexão com o servidor remoto com a seguinte mensagem de erro: O cliente não pode se conectar ao destino especificado na solicitação. Verifique se o serviço de destino está em execução e se está aceitando solicitações. Consulte os logs e a documentação do serviço WS-Management em execução no destino, mais comumente IIS ou WinRM. Se o destino for o serviço WinRM, execute o seguinte comando no destino para analisar e configurar o serviço WinRM: “winrm quickconfig”. Para obter mais informações, consulte o tópico da Ajuda about_Remote_Troubleshooting. em System.Management.Automation.Runspaces.AsyncResult.EndInvoke()

Causa

Esse erro ocorrerá se a configuração de identidade não estiver configurada corretamente ou se ela estiver configurado para o pool de aplicativos errado.

Solução

Defina a configuração de Identidade no pool de aplicativos anexado ao Integration Broker. Ele pode ser diferente do Pool de Aplicativos Padrão.

Para verificar o pool de aplicativos correto:

  1. No Gerenciador do IIS, clique em Pools de Aplicativos no painel esquerdo.
  2. Clique com botão direito do mouse no pool de aplicativos e selecione Exibir Aplicativos.
  3. Confirme se o Integration Broker é exibido na lista de aplicativos.

Para configurar a configuração de Identidade para o pool de aplicativos, siga as instruções em Definir configurações do Gerenciador do IIS para o Integration Broker do Workspace ONE Access.