É possível que um problema de comunicação entre o Integration Broker e o SDK do PowerShell impeça que os aplicativos e desktops publicados da Citrix apareçam no catálogo do Workspace ONE Access.

É possível especificar as URLs em um navegador para diagnosticar e solucionar problemas onde houver um erro de configuração no Integration Broker. Esse método de diagnóstico e solução de problema pode ajudá-lo a identificar um erro de configuração nas seguintes áreas.
  • O farm de servidores Citrix
  • Recursos publicados Citrix
  • Direitos de recursos

Caso uma página da Web não exiba a saída esperada, ela mostrará um erro e adicionará informações aos logs do Integration Broker. Verifique os logs do Integration Broker para continuar o processo de diagnóstico e solução de problemas.

Problema

Após realizar a implantação Citrix com o Workspace ONE Access, os recursos publicados Citrix não aparecem no catálogo do Workspace ONE Access.

Causa

Pode haver um problema de configuração na instalação do Integration Broker que impeça a comunicação adequada com o SDK do PowerShell.

Solução

  1. Use um navegador para verificar as informações do farm de servidores Citrix.
    1. Em um navegador, digite uma URL, tal como uma das seguintes, substituindo os espaços reservados pelas informações adequadas.
      • Farm de servidores Citrix 7.x

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServerHostname&xenappversion=Version7x

      • Citrix Server Farm 6.5

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServerHostname&xenappversion=Version65orLater

      • Farm de servidores Citrix 5.5 ou 6.0

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServerHostname&xenappversion=Legacy

    2. Verifique o conteúdo da página da Web e, se necessário, verifique os logs do Integration Broker.
      Caso o Integration Broker esteja adequadamente configurado, a página exibirá as informações do farm de servidores Citrix, tal como apresentaremos a seguir.

      "[{\"FarmName\":\"test data\",\"ServerVersion\":\" 6.0.6410\",\"AdministratorType\":\"Full\",\"SessionCount\":\"2\",\"MachineName\":\"test data\"}]”

      Caso a página da Web não exiba as informações do farm de servidores, as informações de log são enviadas ao Integration Broker. Para encontrar mais possibilidades de diagnóstico e de soluções para o problema, analise os logs no host do Integration Broker em %programdata%/VMware/HorizonIntegrationBroker.

  2. Use um navegador para listar todos recursos publicados Citrix no farm de servidores.
    1. Em um navegador, digite uma URL, tal como uma das seguintes, substituindo os espaços reservados pelas informações adequadas.
      • Farm de servidores Citrix 7.x

        Para listar todos os aplicativos:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServerHostname&xenappversion=Version7x

        Para listar todos os grupos de distribuição:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/deliveryGroups?computerName=XenAppServerHostname&xenappversion=Version7x

      • Citrix Server Farm 6.5

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServerHostname&xenappversion=Version65orLater

      • Farm de servidores Citrix 5.5 ou 6.0

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServerHostname&xenappversion=Legacy

    2. Verifique o conteúdo da página da Web e, se necessário, verifique os logs do Integration Broker.
      Caso o Integration Broker esteja adequadamente configurado, a página exibirá uma lista de todos os recursos no farm de servidores Citrix.

      Caso a página da Web não exiba a lista de recursos, as informações de log serão enviadas ao Integration Broker. Para encontrar mais possibilidades de diagnóstico e de soluções para o problema, analise os logs no host do Integration Broker em %programdata%/VMware/HorizonIntegrationBroker.

  3. Use um navegador para verificar os direitos para um único recurso Citrix publicado.
    1. Em um navegador, digite uma URL, tal como uma das seguintes, substituindo os espaços reservados pelas informações adequadas.
      Substitua o espaço reservado ApplicationName pelo nome do aplicativo que você estiver especificando.
      • Farm de servidores Citrix 7.x

        Para verificar um aplicativo:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServerHostname&xenappversion=Version7x&appName=ApplicationName

        Para verificar um grupo de distribuição:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/deliveryGroup/entitlements?computerName=XenAppServerHostname&xenappversion=Version7x&deliveryGroupName=deliveryGroupName

      • Citrix Server Farm 6.5

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServerHostname&xenappversion=Version65orLater&appName=ApplicationName

      • Farm de servidores Citrix 5.5 ou 6.0

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServerHostname&xenappversion=Legacy&appName=ApplicationName

    2. Verifique o conteúdo da página da Web e, se necessário, verifique os logs do Integration Broker.
      Caso o Integration Broker esteja adequadamente configurado, a página exibirá uma lista de todos os direitos para o aplicativo ou grupo de distribuição que você especificou.

      Caso a página da Web não exiba a lista de direitos, as informações de log serão enviadas ao Integration Broker. Para encontrar mais possibilidades de diagnóstico e de soluções para o problema, analise os logs no host do Integration Broker em %programdata%/VMware/HorizonIntegrationBroker.