Você faz login em um componente vCenter Server do vSphere Client. Você usa seu nome de usuário e senha do Active Directory. A autenticação falha.

Problema

Você adiciona uma origem de identidade Active Directory a vCenter Single Sign-On, mas os usuários não podem fazer login em vCenter Server.

Causa

Os usuários usam o nome de usuário e a senha para fazer login no domínio padrão. Para todos os outros domínios, os usuários devem incluir o nome do domínio (usuário@domínio ou DOMÍNIO\usuário).

Solução

Para todas as implantações de vCenter Single Sign-On, você pode alterar a origem de identidade padrão. Após essa alteração, os usuários poderão fazer login na origem de identidade padrão apenas com o nome de usuário e a senha.

Para configurar sua fonte de identidade de Autenticação Windows Integrada com um domínio filho dentro de sua floresta Active Directory, consulte o artigo da base de conhecimento VMware em http://kb.vmware.com/kb/2070433. Por padrão, a Autenticação Windows Integrada usa o domínio raiz da sua floresta Active Directory.

Se a alteração da fonte de identidade padrão não resolver o problema, execute as seguintes etapas adicionais de solução de problemas.
  1. Sincronize os relógios entre os controladores de domínio vCenter Server e Active Directory.
  2. Verifique se cada controlador de domínio tem um registro de ponteiro (PTR) no serviço DNS do domínio Active Directory.

    Verifique se as informações do registro PTR do controlador de domínio correspondem ao nome DNS do controlador. Ao usar o vCenter Server, execute os seguintes comandos para executar a tarefa:
    1. Para listar os controladores de domínio, execute o seguinte comando:
      # dig SRV _ldap._tcp.my-ad.com
      Os endereços relevantes estão na seção de resposta, como no exemplo a seguir:
      ;; ANSWER SECTION:
      _ldap._tcp.my-ad.com. (...) my-controller.my-ad.com
      ...
    2. Para cada controlador de domínio, verifique a resolução direta e reversa executando o seguinte comando:
      # dig my-controller.my-ad.com
      Os endereços relevantes estão na seção de resposta, como no exemplo a seguir:
      ;; ANSWER SECTION:
      my-controller.my-ad.com (...) IN A controller IP address
      ...
      # dig -x <controller IP address>
      Os endereços relevantes estão na seção de resposta, como no exemplo a seguir:
      ;; ANSWER SECTION:
      IP-in-reverse.in-addr.arpa. (...) IN PTR my-controller.my-ad.com
      ...
  3. Se isso não resolver o problema, remova o vCenter Server do domínio Active Directory e entre novamente no domínio. Consulte a documentação do vCenter Server Configuração.
  4. Feche todas as sessões do navegador conectadas ao vCenter Server e reinicie todos os serviços.
    /bin/service-control --restart --all