A instalação do vCenter Single Sign-On exibe um erro referindo-se ao vCenter Server ou ao vSphere Client.

Problema

Os instaladores do cliente vCenter Server e Web mostram o erro Could not contact Lookup Service. Please check VM_ssoreg.log....

Causa

Esse problema tem várias causas, incluindo relógios não sincronizados nas máquinas host, bloqueio de firewall e serviços que devem ser iniciados.

Solução

  1. Verifique se os relógios nas máquinas host que executam vCenter Single Sign-On, vCenter Server e o Cliente Web estão sincronizados.
  2. Exiba o arquivo de log específico encontrado na mensagem de erro.
    Na mensagem, a pasta temporária do sistema se refere a %TEMP%.
  3. No arquivo de log, procure as mensagens a seguir.
    O arquivo de log contém a saída de todas as tentativas de instalação. Localize a última mensagem que mostra Initializing registration provider...
    Mensagem Causa e solução
    java.net.ConnectException: Connection timed out: connect O endereço IP está incorreto, um firewall está bloqueando o acesso a vCenter Single Sign-On ou vCenter Single Sign-On está sobrecarregado.

    Certifique-se de que um firewall não esteja bloqueando a porta vCenter Single Sign-On (por padrão, 7444). Certifique-se também de que a máquina na qual o vCenter Single Sign-On está instalado tenha capacidade livre adequada de CPU, E/S e RAM.

    java.net.ConnectException: Connection refused: connect O endereço IP ou o FQDN está incorreto e o serviço vCenter Single Sign-On não foi iniciado ou foi iniciado no último minuto.

    Verifique se vCenter Single Sign-On está funcionando verificando o status do daemon vCenter Single Sign-On vmware-sso.

    Reinicie o serviço. Se a reinicialização não corrigir o problema, consulte a seção de recuperação do vSphereGuia de solução de problemas.

    Unexpected status code: 404. SSO Server failed during initialization Reinicie vCenter Single Sign-On. Se a reinicialização não corrigir o problema, consulte a seção Recuperação do vSphereGuia de solução de problemas.
    O erro mostrado na interface do usuário começa com Could not connect to vCenter Single Sign-On Você também verá o código de retorno SslHandshakeFailed. Esse erro indica que o endereço IP ou o FQDN fornecido que resolve para o host vCenter Single Sign-On não era o endereço usado quando você instalou o vCenter Single Sign-On.

    Em VM_ssoreg.log, localize a linha que contém a seguinte mensagem.

    host name in certificate did not match: <install-configured FQDN or IP> != <A> or <B> or <C> em que A era o FQDN que você inseriu durante a instalação do vCenter Single Sign-On e B e C são alternativas permitidas geradas pelo sistema.

    Corrija a configuração para usar o FQDN à direita de != entrar no arquivo de log. Na maioria dos casos, use o FQDN que você especificou durante a instalação do vCenter Single Sign-On.

    Se nenhuma das alternativas for possível em sua configuração de rede, recupere sua configuração SSL vCenter Single Sign-On.