Em um ambiente de alta disponibilidade vRealize Automation, o Identity Manager pode não iniciar após o reinício do serviço do espaço de trabalho do Horizon.

Problema

O serviço do espaço de trabalho do Horizon não inicia devido a um erro semelhante a este:

Error creating bean with name
  'liquibase' defined in class path resource [spring/datastore-wireup.xml]:
  Invocation of init method failed; nested exception is
  liquibase.exception.LockException: Could not acquire change log lock. Currently
  locked by fe80:0:0:0:250:56ff:fea8:7d0c%eth0
  (fe80:0:0:0:250:56ff:fea8:7d0c%eth0) since 10/29/15 

Causa

O Identity Manager pode não iniciar em um ambiente de alta disponibilidade devido a problemas com o utilitário de gerenciamento de dados liquibase usado por vRealize Automation.

Solução

  1. Faça login no vRealize Automation appliance usando o SSH.
  2. Execute o comando service horizon-workspace para interromper o serviço do espaço de trabalho do Horizon.
  3. Execute o comando su postgres para se tornar um usuário Postgres.
  4. Execute o comando psql vcac.
  5. Defina o esquema para saas.
  6. Execute esta consulta SQL: "update "databasechangeloglock" set locked=FALSE, lockgranted=NULL, lockedby=NULL where id=1;"
  7. Execute a consulta SQL select * do databasechangeloglock.

    A saída deve mostrar um valor de "f" para bloqueado.

  8. Inicie o serviço do espaço de trabalho do Horizon usando o comando service horizon-workspace start.