要将 VMware Cloud Director 升级到新版本,需要关闭服务器组中所有单元上的 VMware Cloud Director 服务,在每台服务器上安装新版本,升级 VMware Cloud Director 数据库,并重新启动 VMware Cloud Director 单元。

如果您的现有 VMware Cloud Director 服务器组包含基于 Linux 的 VMware Cloud Director 安装,则可以使用适用于 Linux 的 VMware Cloud Director 安装程序升级您的环境。

对于 Linux 上的 VMware Cloud Director 安装,可以执行协调升级,也可以手动升级 VMware Cloud Director。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装。通过协调升级,运行单个命令即可升级服务器组中的所有单元以及数据库。通过手动升级,按顺序升级每个单元和数据库。

VMware Cloud Director 9.5 开始:
  • 不支持 Oracle 数据库。如果您的现有 VMware Cloud Director 安装使用 Oracle 数据库,请参见升级和迁移途径表。
  • 不支持启用和禁用 ESXi 主机。开始升级之前,必须启用所有 ESXi 主机。可以使用 vSphere ClientESXi 主机置于维护模式。
  • VMware Cloud Director 使用具有增强型 LDAP 支持的 Java。如果使用的是 LDAPS 服务器,为避免 LDAP 登录失败,必须确认具有构造正确的证书。有关信息,请参见《Java 8 版本变更》,网址为 https://www.java.com

VMware Cloud Director 10.0 开始,不再支持 Microsoft SQL Server 数据库。

升级 VMware Cloud Director 时,新版本必须与现有安装的以下组件兼容:
  • 当前用于 VMware Cloud Director 数据库的数据库软件。有关详细信息,请参见“升级和迁移途径”表。
  • 当前使用的 VMware vSphere ® 版本。
  • 当前使用的 VMware NSX® 版本。
  • 直接与 VMware Cloud Director 交互的任何第三方组件。

有关 VMware Cloud Director 与其他 VMware 产品及第三方数据库的兼容性信息,请参见《VMware 产品互操作性列表》,网址为 http://partnerweb.vmware.com/comp_guide/sim/interop_matrix.php。如果打算在 VMware Cloud Director 升级过程中升级 vSphereNSX 组件,则必须在升级 VMware Cloud Director 之后进行。请参见升级 VMware Cloud Director 之后

至少升级一台 VMware Cloud Director 服务器后,可以升级 VMware Cloud Director 数据库。该数据库负责存储有关服务器的运行时状态的信息,包括正在运行的所有 VMware Cloud Director 任务的状态。要确保升级后数据库中的任务信息均有效,必须在开始升级之前确认任何服务器上均没有处于活动状态的任务。

升级过程还将保留以下未存储在 VMware Cloud Director 数据库中的项目:

  • 本地和全局属性文件复制到新安装。
  • 将用于客户机自定义支持的 Microsoft Sysprep 文件复制到新安装。

升级需要足够长的 VMware Cloud Director 停机时间,以便升级服务器组的所有服务器和数据库。如果使用负载均衡器,可以将其配置为返回一条消息,例如,系统处于脱机状态,无法升级 (The system is offline for upgrade)。

从版本 10.1 开始,服务提供商和租户可以使用 VMware Cloud Director API 测试与远程服务器的连接,并在 SSL 握手过程中验证服务器身份。为了保护 VMware Cloud Director 网络连接,请配置一个内部主机拒绝列表,使用 VMware Cloud Director API 进行连接测试的租户无法访问这些主机。在安装或升级 VMware Cloud Director 之后,请先配置此拒绝列表,然后再向租户授予对 VMware Cloud Director 访问权限。请参见配置测试连接拒绝列表

重要事项: 升级到版本 10.1 后, VMware Cloud Director 始终会验证与其连接的任何基础架构端点的证书。这是因为 VMware Cloud Director 管理 SSL 证书的方式发生了变化。如果在升级之前未将证书导入到 VMware Cloud Director,则由于 SSL 验证问题, vCenter ServerNSX 连接可能会显示连接失败错误。在这种情况下,升级后有两个选择:
  1. 运行单元管理工具 trust-infra-certs 命令以自动将所有证书导入到集中式证书存储中。请参见从 vSphere 资源导入端点证书
  2. Service Provider Admin Portal UI 中,选择每个 vCenter ServerNSX 实例,然后在接受证书时重新输入凭据。

升级途径和工作流

源环境 目标环境
Linux 上具有外部 PostgreSQL 数据库的 VMware Cloud Director 10.1
具有外部 Oracle 数据库的 VMware Cloud Director 9.0 和 9.1
  1. 对于 Linux 上的 VMware Cloud Director 9.0,请将 VMware Cloud Director 升级到版本 9.1。请参见升级 vCloud Director
  2. 将 Oracle 数据库迁移到 PostgreSQL 数据库。请参见迁移到 PostgreSQL 数据库
  3. 将您的环境升级到 Linux 上的 VMware Cloud Director 10.1。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装
具有外部 PostgreSQL 数据库的 VMware Cloud Director 设备 9.5 不受支持
Linux 上具有外部 PostgreSQL 数据库的 VMware Cloud Director 9.0、9.1 和 9.5 将您的环境升级到 Linux 上的 VMware Cloud Director 10.1。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装
Linux 上具有外部 Microsoft SQL Server 数据库的 VMware Cloud Director 9.0、9.1 和 9.5
  1. 将您的环境升级到 Linux 上的 VMware Cloud Director 9.7。请参见升级 vCloud Director
  2. 将 Microsoft SQL Server 数据库迁移到 PostgreSQL 数据库。请参见迁移到 PostgreSQL 数据库
  3. 将您的环境升级到 Linux 上的 VMware Cloud Director 10.1。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装
Linux 上使用外部 Microsoft SQL Server 数据库的 VMware Cloud Director 9.7
  1. 将 Microsoft SQL Server 数据库迁移到 PostgreSQL 数据库。请参见迁移到 PostgreSQL 数据库
  2. 将您的环境升级到 Linux 上的 VMware Cloud Director 10.1。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装
Linux 上具有外部 PostgreSQL 数据库的 VMware Cloud Director 9.7 和 10.0 将您的环境升级到 Linux 上的 VMware Cloud Director 10.1。请参见执行 VMware Cloud Director 安装的协调升级手动升级 VMware Cloud Director 安装
具有嵌入式 PostgreSQL 数据库的 VMware Cloud Director 设备 9.7 和 10.0 不受支持