虚拟机兼容性决定对虚拟机可用的虚拟硬件。您可调度兼容性升级,使虚拟机与更新版本的 ESXi 兼容。

您可以通过升级其兼容性或调度兼容性升级更改单个虚拟机的兼容性。

您还可以为主机、群集或数据中心更改默认兼容性设置。

前提条件

  • 创建虚拟机的备份或快照。请参见使用快照管理虚拟机
  • 升级到最新版本的 VMware Tools。如果在升级 VMware Tools 之前升级兼容性,则虚拟机可能会丢失其网络设置。
  • 确认所有 .vmdk 文件是否对 VMFS3、VMFS5 或 NFS 数据存储上的 ESXi 主机可用。
  • 确认虚拟机是否存储于 VMFS3、VMFS5 或 NFS 数据存储上。
  • 验证虚拟机的兼容性设置是否并非为支持的最新版本。
  • 确定您希望虚拟机与之兼容的 ESXi 版本。请参见虚拟机兼容性

过程

  1. (可选) 要确定虚拟机的兼容性设置,请选择清单中的虚拟机,然后单击摘要选项卡。
  2. 选择任务。
    客户端 任务
    vSphere Client
    • 更改虚拟机的默认兼容性设置。
      • 右键单击虚拟机,然后单击兼容性 > 升级虚拟机兼容性
      • 右键单击虚拟机,然后单击兼容性 > 调度虚拟机兼容性升级