用于安装 Horizon Client 的 Linux PC 或笔记本电脑及其使用的外围设备必须满足特定系统要求。

注: 这些系统要求适用于 VMware 提供的适用于 Linux 的 Horizon Client。此外,还有一些 VMware 合作伙伴提供了面向 View 部署的瘦客户端设备和零客户端设备。每个瘦客户端设备或零客户端设备可用的功能和支持的操作系统由供应商、型号以及企业选择使用的配置决定。有关这些客户端设备的供应商和型号的信息,请参阅 VMware 网站上的 VMware 兼容性指南
注:
  • 从 7.0 版本开始,View Agent 被重新命名为 Horizon Agent
  • Horizon Client 4.0 和 Horizon Agent 7.0 起可以使用的显示协议 VMware Blast 现在还称为 VMware Blast Extreme。
架构
基于 Intel、ARM
内存
最少 2GB RAM
操作系统
  • Horizon Client 4.0 支持以下操作系统。
    操作系统 版本
    Ubuntu 12.04 和 14.04
    Ubuntu x64 12.04 和 14.04
    Red Hat Enterprise Linux (RHEL) 6.7、7.2
    SUSE Linux Enterprise Desktop (SLED) 11 SP4
    CentOS 6.7
  • Horizon Client 3.5 支持以下操作系统。
    操作系统 版本
    Ubuntu 12.04 和 14.04
    Ubuntu x64 12.04
    Red Hat Enterprise Linux (RHEL) 6.6 和 6.7
    SUSE Linux Enterprise Desktop (SLED) 11 SP3
    CentOS 6.6
    重要事项: Ubuntu 12.04 是支持的唯一 64 位 Linux 发布版本。
  • Horizon Client 3.4 支持以下操作系统。
    操作系统 版本
    Ubuntu 12.04 和 14.04
    Red Hat Enterprise Linux (RHEL) 6.6
    SUSE Linux Enterprise Desktop (SLED) 11 SP3
    CentOS 6.6
    重要事项: 仅支持 32 位系统。
  • Horizon Client 3.2 支持以下操作系统。
    操作系统 版本
    Ubuntu 12.04 和 14.04
    Red Hat Enterprise Linux (RHEL) 6.5
    SUSE Linux Enterprise Desktop (SLED) 11 SP3
    CentOS 6.5
    重要事项: 仅支持 32 位系统。
  • Horizon Client 3.1 支持以下操作系统。
    操作系统 版本
    Ubuntu 12.04 和 14.04
    重要事项: 仅支持 32 位系统。
OpenSSL 要求

Horizon Client 需要特定版本的 OpenSSL。如果您拥有 Horizon Client 3.4 或更高版本,将自动下载并安装正确的版本。如果您拥有 Horizon Client 3.2 或更低版本,在您没有安装正确版本的 OpenSSL 时,客户端可能出现没有启动、意外退出或无法连接到服务器的问题。客户端可能也容易遭受正在使用的旧版本库中存在的安全缺陷的攻击。

表 1. 特定版本的 Horizon Client 的 OpenSSL 要求
客户端版本 要求
Horizon Client 4.0 OpenSSL 1.0.2f 或更高版本。为方便起见,如果您没有正确版本的 OpenSSL,Horizon Client 安装程序将下载并安装所需版本的 OpenSSL
Horizon Client 3.4 和 3.5 OpenSSL 1.0.1m 或更高版本。为方便起见,如果您没有正确版本的 OpenSSL,Horizon Client 安装程序将下载并安装所需版本的 OpenSSL
Horizon Client 3.2 OpenSSL 1.0.1i 或更高版本。
重要事项: 如果从 OpenSSL 网站或一些其他站点下载 OpenSSL 1.0.1i 的源代码,并对其进行编译和安装,您可能会获得具有扩展 1.0.0 或 1.0.1i 的库,但 Horizon Client 会查找具有扩展 1.0.1 的库。具体来说,客户端会在系统的库路径中查找名为 libssl.so.1.0.1libcrypto.so.1.0.1 的文件。要解决此问题,您可以通过以下方法创建符号链接:将 libssl.so.1.0.1 链接至 libssl.so.1.0.1ilibssl.so.1.0.0,并将 libcrypto.so.1.0.1 链接至 libcrypto.so.1.0.1ilibcrypto.so.1.0.0(视情况而定)。
Horizon Client 3.1 OpenSSL 1.0.1h
View 连接服务器、安全服务器和 View Agent
View 5.3.x 的最新维护版本和更高版本

如果客户端系统是从企业防火墙以外连接,VMware 建议您使用安全服务器。如果使用安全服务器,客户端系统就不需要 VPN 连接。

远程(托管)应用程序仅在 Horizon 6.0(或更高版本)View Server 上可用。

显示协议
  • VMware Blast(需要使用 Horizon Client 4.0 或更高版本,以及 Horizon Agent 7.0 或更高版本)
  • PCoIP
  • RDP
客户端系统的屏幕分辨率
最低:1024 X 768 像素
VMware Blast 和 PCoIP 的硬件要求
  • 具有 SSE2 扩展指令集、基于 x86 或 x64 的处理器,处理器速度为 800 MHz 或更高。
  • 高于系统要求的可用 RAM,用于支持各种显示器设置。以下公式可用作一般指南:
    20MB + (24 * (# monitors) * (monitor width) * (monitor height))
    
    您可以使用以下计算进行粗略估计:
    1 monitor: 1600 x 1200: 64MB
    2 monitors: 1600 x 1200: 128MB
    3 monitors: 1600 x 1200: 256MB
    
RDP 的硬件要求
  • 具有 SSE2 扩展指令集、基于 x86 或 x64 的处理器,处理器速度为 800 MHz 或更高。
  • 128 MB RAM。
Microsoft RDP 的软件要求
  • 对于 Ubuntu 12.04,使用 rdesktop 1.7.0。
FreeRDP 的软件要求
如果您想要使用 RDP 连接到 View 桌面,并且您更倾向于用 FreeRDP 客户端进行连接,那么您必须安装正确的 FreeRDP 版本及全部适用的补丁程序。请参阅 安装并配置 FreeRDP
其他软件要求
Horizon Client 还有一些其他软件要求,具体取决于您所使用的 Linux 发布版本。请务必允许 Horizon Client 安装向导针对库兼容性和依赖关系对系统进行扫描。以下列出的要求仅适用于 Ubuntu 发布版本。
  • 要支持闲置会话超时:libXsso.so.1
  • 要支持 Flash URL 重定向:libexpat.so.1。(不再需要 libexpat.so.0 文件。)
  • 要支持 USB 重定向和实时音频-视频:libudev0
    注: 默认情况下,Ubuntu 14.04 中未安装 libudev0
  • 要在使用多台显示器时改善性能,请启用 Xinerama。