某些功能并不适用于全部类型的 Horizon Client

在计划要将哪些显示协议和功能提供给最终用户时,可根据下面的信息来确定哪些客户端操作系统支持这些功能。
注: 客户端驱动器重定向是 Horizon Client 3.5 中的一项技术预览功能。 Horizon Client 4.0 和更高版本中已完全支持该功能。
表 1. Linux 客户端上支持的远程桌面功能
功能 Windows XP 桌面(View Agent 6.0.2 和更低版本) Windows Vista 桌面(View Agent 6.0.2 和更低版本) Windows 7 桌面 Windows 8.x 桌面 Windows 10 桌面 Windows Server 2008 R2 桌面 Windows Server 2012 R2 桌面
USB 重定向 受限 受限 X X X X X
实时音频-视频 (RTAV) 受限 受限 X X X X X
扫描仪重定向
串行端口重定向
RDP 显示协议 受限 受限 X X X X X
PCoIP 显示协议 受限 受限 X X X X X
VMware Blast 显示协议 X X X X X
用户配置管理
Wyse MMR 仅合作伙伴客户端系统,仅使用 RDP 仅合作伙伴客户端系统,仅使用 RDP
Windows Media MMR
基于位置的打印 受限 受限 X X X X X
虚拟打印 受限 受限 X X X X X
智能卡 受限 受限 X X X X X
RSA SecurID 或 RADIUS 受限 受限 X X X X X
单点登录 受限 受限 X X X X X
多显示器 受限 受限 X X X X X
客户端驱动器重定向 X X X X X

Windows 10 桌面需要 View Agent 6.2 或更高版本。Windows Server 2012 R2 桌面需要 View Agent 6.1 或更高版本。

VMware Blast 需要使用 Horizon Client 4.0 或更高版本以及 Horizon Agent 7.0 或更高版本。

重要事项: View Agent 6.1 和更高版本不支持 Windows XP 和 Windows Vista 桌面。View Agent 6.0.2 是支持这些客户机操作系统的上一个 View 版本。与 Microsoft 签订有关 Windows XP 和 Vista 的扩展支持协议以及与 VMware 签订有关这些客户机操作系统的扩展支持协议的客户可以使用 View 连接服务器 6.1 部署其 Windows XP 和 Vista 桌面的 View Agent 6.0.2 版本。

RDS 主机上基于会话的桌面的功能支持表

RDS 主机是安装了 Windows 远程桌面服务以及 View Agent 或 Horizon Agent 的服务器计算机。多个用户可以同时在一个 RDS 主机上拥有桌面会话。RDS 主机可以是物理机或虚拟机。

注: 下表只包含对应于支持的功能的行。在文字指定 View Agent 最低版本的地方,文字“和更高版本”表示包含 Horizon Agent 7.0 和更高版本。
表 2. 安装了 View Agent 6.0.x 或更高版本或者 Horizon Agent 7.0 或更高版本的 RDS 主机支持的功能
功能 物理机上的 Windows Server 2008 R2 RDS 主机 虚拟机上的 Windows Server 2008 R2 RDS 主机 物理机上的 Windows Server 2012 RDS 主机 虚拟机上的 Windows Server 2012 RDS 主机
RSA SecurID 或 RADIUS X X X X
智能卡 View Agent 6.1 和更高版本 View Agent 6.1 和更高版本 View Agent 6.1 和更高版本 View Agent 6.1 和更高版本
单点登录 X X X X
RDP 显示协议(适用于桌面客户端) X X X X
PCoIP 显示协议 X X X X
VMware Blast 显示协议 Horizon Agent 7.0 和更高版本 Horizon Agent 7.0 和更高版本 Horizon Agent 7.0 和更高版本 Horizon Agent 7.0 和更高版本
HTML Access View Agent 6.0.2 和更高版本 View Agent 6.0.2 和更高版本
客户端驱动器重定向 View Agent 6.1.1 和更高版本 View Agent 6.1.1 和更高版本 View Agent 6.1.1 和更高版本 View Agent 6.1.1 和更高版本
虚拟打印(适用于桌面客户端) View Agent 6.0.1 和更高版本 View Agent 6.0.1 和更高版本
基于位置的打印 View Agent 6.0.1 和更高版本 View Agent 6.0.1 和更高版本
多个显示器(适用于桌面客户端) X X X X
Unity Touch(适用于移动客户端) X X X X
注: 智能卡功能也需要使用 Horizon Client 3.4 或更高版本。

有关支持的各个客户机操作系统的版本及服务包信息,请参阅 View 5.x 或 6.x 安装指南文档中的“View Agent 支持的操作系统”主题。请参阅 Horizon 7 安装文档中的“Horizon Agent 支持的操作系统”主题。

特定功能的限制

使用适用于 Linux 的 Horizon Client 的 Windows 桌面支持的功能存在以下限制。

表 3. 特定功能的要求
功能 要求
实时音频-视频
  • 对于第三方供应商提供的 Horizon Client,此功能需要 View 5.2 Feature Pack 2 或更高版本。
  • 对于 VMware 提供的客户端软件,您必须具备 Horizon Client 3.2 和更高版本以及 View Agent 6.0.2 和更高版本。

需要使用 VMware Blast 或 PCoIP 显示协议。

适用于 Windows Server 2008 R2 桌面、RDS 桌面(在虚拟机 RDS 主机上)以及远程应用程序的虚拟打印和基于位置的打印
  • 对于合作伙伴客户端软件,需要 Horizon Client 3.1 和更高版本以及 Horizon 6.0.1(包含 View)和更高版本的服务器。
  • 对于 VMware 提供的客户端软件,需要 Horizon Client 3.2 和更高版本以及 View Agent 6.0.2 和更高版本。需要使用 VMware Blast 或 PCoIP 显示协议。
USB 重定向
  • 对于合作伙伴客户端软件,需要 View 5.1 以及更高版本的服务器和桌面。
  • 对于 VMware 提供的客户端软件,需要 Horizon Client 3.2 和更高版本以及 View Agent 6.0.2 和更高版本。

需要使用 VMware Blast 或 PCoIP 显示协议。

智能卡 对于单用户虚拟机桌面,需要 Horizon Client 3.2 或更高版本以及 View Agent 6.0.2 和更高版本。

对于 RDS 主机上基于会话的桌面,需要 Horizon Client 3.4 和更高版本以及 View Agent 6.1 和更高版本。

客户端驱动器重定向 对于 RDS 主机上的单用户虚拟机桌面和基于会话的桌面,需要 Horizon Client 3.5 和更高版本以及 View Agent 6.1.1 和更高版本。
注: 除了访问远程桌面外,您还可以使用 Horizon Client 安全访问基于 Windows 的远程应用程序。在 Horizon Client 中选择一个应用程序时,会在本地客户端设备上打开一个该应用程序的窗口,而且应用程序的外观和行为就像安装在本地设备上一样。

只有在连接到连接服务器 6.0 或更高版本时,才能使用远程应用程序。有关 RDS(远程桌面会话)主机(它提供远程应用程序和基于会话的桌面)支持的操作系统的信息,请参阅《View 5.x 或 6.x 安装指南》文档中的“Horizon Agent 支持的操作系统”主题。请参阅 Horizon 7 安装文档中的“Horizon Agent 支持的操作系统”主题。

注: 每种瘦客户端设备上的可用功能由供应商、设备型号以及企业选择使用的配置决定。有关瘦客户端设备的供应商和型号信息,请参阅 http://www.vmware.com/resources/compatibility/search.php?deviceCategory=vdm 上的 “VMware 兼容性指南”

有关上述功能及其限制的说明,请参阅View 规划指南》文档。

Linux 桌面的功能支持

如果您拥有 View Agent 6.1.1 或更高版本以及 Horizon Client 3.4 或更高版本,则支持某些 Linux 客户机操作系统。有关支持的 Linux 操作系统列表以及支持的功能的信息,请参 Horizon 6 版本 6.1 文档中包含的《设置 Horizon 6 for Linux 桌面》