全局客户端限制设置可将虚拟桌面、已发布桌面和已发布应用程序的启动限制为特定的客户端和版本,并且还可以向客户端提供警告消息。

Horizon Console 中,您可以通过导航到设置 > 全局设置 > 客户端限制设置来配置全局客户端限制设置。

客户端限制适用于 Horizon Client 版本 4.5.0 或更高版本,但适用于 Chrome 的 Horizon Client 除外,该类型的客户端必须是版本 4.8.0 或更高版本。在配置此功能后,将阻止相应客户端类型的特定 Horizon Client 版本或较低版本连接到远程桌面和已发布的应用程序。用于向特定客户端版本显示警告消息的功能适用于 Horizon Client 2006 或更高版本。

注: 客户端限制设置仅阻止最终用户启动远程桌面和已发布的应用程序。此功能不会阻止最终用户登录 VMware Horizon
表 1. 客户端会话的全局客户端限制设置
设置 说明
适用于 Windows 的 Horizon Client 对于阻止以下版本客户端的连接设置,请选择以下选项之一:
  • 低于:指定最低客户端版本以阻止低于该版本的所有客户端。
  • 特定:输入特定版本(以逗号分隔),以在用户使用这些客户端版本进行连接时阻止用户。

对于当用户从特定的客户端版本连接时发出警告设置,请输入以逗号分隔的版本,以当用户从这些客户端版本连接时发出警告。

适用于 Linux 的 Horizon Client 对于阻止以下版本客户端的连接设置,请选择以下选项之一:
  • 低于:指定最低客户端版本以阻止低于该版本的所有客户端。
  • 特定:输入特定版本(以逗号分隔),以在用户使用这些客户端版本进行连接时阻止用户。

对于当用户从特定的客户端版本连接时发出警告设置,请输入以逗号分隔的版本,以当用户从这些客户端版本连接时发出警告。

适用于 Mac 的 Horizon Client 对于阻止以下版本客户端的连接设置,请选择以下选项之一:
  • 低于:指定最低客户端版本以阻止低于该版本的所有客户端。
  • 特定:输入特定版本(以逗号分隔),以在用户使用这些客户端版本进行连接时阻止用户。

对于当用户从特定的客户端版本连接时发出警告设置,请输入以逗号分隔的版本,以当用户从这些客户端版本连接时发出警告。

适用于 iOS 的 Horizon Client 对于阻止以下版本客户端的连接设置,请选择以下选项之一:
  • 低于:指定最低客户端版本以阻止低于该版本的所有客户端。
  • 特定:输入特定版本(以逗号分隔),以在用户使用这些客户端版本进行连接时阻止用户。

对于当用户从特定的客户端版本连接时发出警告设置,请输入以逗号分隔的版本,以当用户从这些客户端版本连接时发出警告。

适用于 Android 的 Horizon Client 对于阻止以下版本客户端的连接设置,请选择以下选项之一:
  • 低于:指定最低客户端版本以阻止低于该版本的所有客户端。
  • 特定:输入特定版本(以逗号分隔),以在用户使用这些客户端版本进行连接时阻止用户。

对于当用户从特定的客户端版本连接时发出警告设置,请输入以逗号分隔的版本,以当用户从这些客户端版本连接时发出警告。

适用于 UWP 的 Horizon Client 输入一个 Horizon Client 版本号,以阻止低于该版本的所有客户端。
适用于 Chrome 的 Horizon Client 输入一个 Horizon Client 版本号,以阻止低于该版本的所有客户端。
适用于 HTML Access 的 Horizon Client 输入一个 Horizon Client 版本号,以阻止低于该版本的所有客户端。
阻止其他客户端 如果选择此选项,将阻止所有其他类型的客户端(加入白名单的 Horizon Client 除外)启动任何桌面或已发布的应用程序。

但是,如果您希望最终用户使用其他类型的客户端来启动桌面和已发布的应用程序,就必须将该客户端类型添加到 pae-AdditionalClientTypes LDAP 属性才能绕过该客户端类型的阻止设置。

您可以使用“ADSI 编辑”实用程序来编辑连接服务器上的 LDAP 属性。

在“ADSI 编辑”实用程序中,pae-AdditionalClientTypes LDAP 属性在 CN=CommonOU=GlobalOU=PropertiesDC=vdiDC=vmwareDC=int 下可用。

对阻止的客户端版本显示的消息 输入要向尝试使用被阻止的 Horizon Client 版本进行连接的用户显示的消息。消息的字符长度限制为 1024。
警告消息 输入要向使用受限制的 Horizon Client 版本进行连接的用户显示的警告消息。消息的字符长度限制为 1024。