Horizon 8 中进行 USB 重定向时可能会出现各种问题。

问题

USB 有其局限性。有关更多信息,请参阅USB 设备类型的相关限制。在大多数用例中,扫描仪重定向、实时音频-视频、串行端口重定向和客户端驱动器重定向功能可以帮助绕过这些限制。VMware 建议使用备用技术(如果可用),因为音频、扫描仪等的 USB 重定向可能会因为网络延迟而变得不可靠。

Horizon Client 中的 USB 重定向功能无法为远程桌面或应用程序启用本地设备,或是某些设备看上去无法用于 Horizon Client 重定向。

原因

USB 重定向可能会由于以下原因而无法正确或按预期运行:
  • 确认虚拟操作系统受支持。请参阅《Horizon 8 安装和升级》文档中的有关 Horizon Agent 的要求和注意事项
    注: 对于部署为 RDSH 服务器的服务器操作系统,支持的设备存在一些限制。存储驱动器和一组有限的轻量级设备类型受支持。例如,CDROM 设备不受支持。
  • 该设备是复合 USB 设备且所包含的其中一个设备被默认阻止。例如,默认情况下,包含鼠标的语音输入设备由于鼠标设备被默认阻止而被阻止。要解决此问题,请参阅为复合 USB 设备配置设备拆分策略设置
  • 默认情况下,适用于 Windows 的 Horizon Client 不允许您选择键盘、鼠标、智能卡和音频输出设备进行重定向。请参阅为 USB 设备配置过滤策略设置
  • 引导设备不支持 USB 重定向。如果在通过 USB 设备引导的 Windows 系统上运行 Horizon Client,而且将该设备重定向到远程桌面,本地操作系统就可能无法响应或不可用。
  • 网络延迟可能造成设备交互缓慢,或导致应用程序因与本地设备交互而表现为冻结。大型 USB 磁盘驱动器可能需要几分钟才能显示在 Windows 资源管理器中,并且可能适用于客户端驱动器重定向。
  • 使用 FAT32 文件系统格式化的 USB 闪存卡加载速度很慢。请参阅知识库文章重定向 USB 闪存驱动器可能需要几分钟时间
  • 在连接到远程桌面或应用程序之前,本地系统上的某个进程或服务已打开该设备。
  • 如果重新连接到桌面或应用程序会话,则已重定向的 USB 设备将停止运行,即使桌面或应用程序显示该设备可用。
  • 在控制台中停用了 USB 重定向。
  • 客户机上缺少或停用了 USB 重定向驱动程序。

解决方案

  • 如果可能,请使用 VMware Blast 或 PCoIP 作为协议,而不使用 RDP。
  • 如果临时断开连接后重定向的设备仍然不可用或停止工作,则需要拔出并重新插入该设备,然后重新尝试重定向。
  • 在控制台中,转到策略 > 全局策略,然后确认已在“查看策略”下将“USB 访问”设置为允许
  • 检查客户机上的日志中的 ws_vhub 类的条目,以及客户端上的日志中的 vmware-view-usbd 类的条目。
    如果用户不是管理员,或者 USB 重定向驱动程序未安装或不能正常运行,这些分类的条目将被写入日志中。有关这些日志文件的位置,请参阅 使用日志文件进行故障排除和确定 USB 设备 ID
  • 打开客户机上的“设备管理器”,展开“通用串行总线控制器”,重新安装(如已丢失)或重新激活(如被停用)VMware View 虚拟 USB 主机控制器和 VMware View 虚拟 USB Hub 驱动程序。