已成功部署 NSX Intelligence 设备,但存在一些已降级的服务。

问题

已成功部署 NSX Intelligence 设备,但设备的运行状况报告为已降级。将在部署 NSX Intelligence 设备后立即报告该已降级运行状况,或者在设备生命周期的以后阶段报告该运行状况。

原因

可能是以下任意原因导致出现上述情况。
  1. NSX Intelligence 上的服务启动取决于从 NSX Manager Unified Appliance 接收特定配置信息的情况。在 NSX Intelligence 首次启动期间,此配置可能需要一些时间才能完成,并且 NSX Intelligence 设备预计会保持已降级状态约 15 分钟。
  2. 如果在 NSX Intelligence 设备生命周期的不同时间观察到该问题,该问题可能是由于以下原因之一引起的。
    1. NSX Intelligence 设备上发生资源争用。
    2. NSX Intelligence 设备上没有足够的可用磁盘空间。
    3. 最近重新引导了 NSX Intelligence 设备。
    4. 关闭了一个或多个 NSX Intelligence 服务。
  3. NSX Intelligence 设备的证书与 NSX Manager Unified Appliance 上的证书不兼容。

解决方案

以下可能的解决方案分别对应上述问题部分中列出的问题。
  1. NSX Intelligence 设备初始部署完成后,必须等待初始配置同步完成。在系统打开电源后等待大约 30 分钟,以使设备达到稳定状态。在 NSX Intelligence 设备不再处于已降级状态后,刷新 Web 浏览器。
  2. 以下是前面第二个原因的可能解决方案。
    1. 如果该问题是由于资源争用引起的,请等待大约 30 分钟以启动 NSX Intelligence 设备的自我修复过程。
    2. 如果该问题是由于磁盘空间分配引起的,请检查 NSX Intelligence 设备警报以查找具有高延迟或高使用率的分区。采取相应的措施以缓解该问题,或者与 VMware 技术支持部门联系以获得更多帮助。
    3. 如果该问题是由于最近重新引导引起的,请等待 NSX Intelligence 设备变为稳定状态。NSX Intelligence 设备可能需要 15 到 30 分钟的时间才能变为稳定状态,具体取决于底层硬件。
    4. 如果该问题是由于手动关闭一个或多个 NSX Intelligence 服务引起的,请重新启动这些服务及其相关服务。在重新启动所有服务后,请等待 10 到 15 分钟的时间以使 NSX Intelligence 设备变为稳定状态。
  3. 确保用于 NSX Manager Unified Appliance 节点或集群的证书与 安装和升级 VMware NSX Intelligence 文档中“准备安装 NSX Intelligence”主题中列出的证书类型兼容。

如果上述解决方案都不起作用,请与您的 VMware 代表联系以获得帮助。