成功激活了 Security Intelligence 功能,但存在一些降级的服务。
问题
成功激活了 Security Intelligence 功能,但其运行状况报告为部分已启动或关闭。将在激活 Security Intelligence 功能后立即报告这些降级的运行状况,或者在其生命周期的以后阶段报告这些运行状况。
原因
可能是以下任意原因导致出现上述情况。
- 无法从 TKC 或上游 Kubernetes worker 节点中访问 Docker 注册表。
- Security Intelligence 应用程序 Pod 无法达到正在运行状态。
解决方案
与 Kubernetes 基础架构管理员一起尝试修复该问题。可以使用以下可能的解决方案,它们对应于前面的“问题”部分中列出的问题。
- 验证所需的所有 Pod 是否能够启动。Pod 启动取决于可访问的 Docker 注册表。如果无法访问 Docker 注册表或下载操作由于身份验证或授权原因失败,Kubernetes worker 节点可能无法下载运行工作负载所需的 Docker 容器映像。修复 Docker 注册表的连接问题,删除 Security Intelligence 功能,然后再次尝试激活该功能。
- 检查所有 Pod 是否达到正在运行状态并成功完成了所有作业。在下载 Docker 容器映像后,Pod 必须能够启动和运行。对于未处于正在运行状态的 Pod,请使用以下 describe 命令检查事件。
napp-k describe pod <pod-name>
对于未成功完成的作业,请使用以下命令检查日志。napp-k logs <pod-name>
如果提供的任何解决方案均无效,请与 VMware 支持部门联系以获得进一步的帮助。