NSX Container Plug-in (NCP) 对 Kubernetes 环境和 Pivotal Cloud Foundry (PCF) 环境具有以下兼容性要求。

表 1. Kubernetes 环境的兼容性要求
软件产品 版本
NSX-T Data Center 2.3、2.4
容器主机虚拟机的管理程序
容器主机操作系统
  • RHEL 7.5、7.6
  • Ubuntu 16.04
  • CentOS 7.4、7.5
容器协调器 Kubernetes 1.12、1.13
容器主机 Open vSwitch 2.9.1(随 NSX-T Data Center 2.3.x 打包)、2.10.2(随 NSX-T Data Center 2.4.0 打包)
表 2. Cloud Foundry 环境的兼容性要求
软件产品 版本
容器主机虚拟机的管理程序
容器协调器
  • Pivotal Application Service 2.3.x 和 Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x(2.4.0 除外)和 Pivotal Operations Manager 2.4.x(2.4.0 除外)