配置 NSX-T Data Center 后,请在 Arista CloudVision eXchange (CVX) 上完成相应的配置过程,以使 CVX 能够与 NSX-T Data Center 进行交互。

前提条件

NSX-T Data Center 已将 CVX 注册为一个实施点。

过程

  1. 以 root 用户身份登录到 NSX Manager,然后运行以下命令以创建 CVX 与 NSX Manager 进行通信时所用的指纹。
    openssl s_client -connect <IP address of nsx-manager>:443 | openssl x509 -pubkey -noout | openssl rsa -pubin -outform der | openssl dgst -sha256 -binary | openssl base64
    示例输出:
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify error:num=18:self signed certificate
    verify return:1
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify return:1
    writing RSA key
    S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
  2. 在 CVX CLI 中运行以下命令:
    cvx
    no shutdown
    service pcs
    no shutdown
    controller <IP address of nsx-manager>
    username <NSX administrator user name>
    password <NSX administrator password>
    enforcement-point cvx-default-ep
    pinned-public-key <thumbprint for CVX to communicate with NSX
    				  Manager>
    notification-id <notification ID created while registering CVX with NSX>
    end
    
  3. 在 CVX CLI 中运行以下命令以检查配置:
    show running-config
    示例输出:
    cvx
          no shutdown
       source-interface Management1
       !
       service hsc
          no shutdown
    
       !
       service pcs
          no shutdown
          controller 192.168.2.80
          username admin
          password 7 046D26110E33491F482F2800131909556B
          enforcement-point cvx-default-ep
          pinned-public-key sha256//S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
          notification-id a0286cb6-de4d-41de-99a0-294465345b80
  4. 在连接到物理服务器的物理交换机的以太网接口上配置 tag。在由 CVX 管理的物理交换机上运行以下命令。
    configure terminal
    interface ethernet 4
    tag phy_app_server
    end
    copy running-config startup-config
    Copy completed successfully.
  5. 运行以下命令以验证交换机的标记配置:
    show running-config section tag
    示例输出:
    interface Ethernet4
       description connected-to-7150s-3
       switchport trunk allowed vlan 1-4093
       switchport mode trunk
       tag sx4_app_server
    

    在标记的接口上使用 ARP 发现的 IP 地址将与 NSX-T Data Center 共享。

  6. 登录到 NSX Manager,以便为由 CVX 管理的物理工作负载创建并发布防火墙规则。有关创建规则的详细信息,请参见安全。例如:

    NSX-T Data Center 中发布的 NSX-T Data Center 策略和规则在由 CVX 管理的物理交换机上显示为动态 ACL。

    有关详细信息,请参见 CVX HA 设置CVX HA 虚拟 IP 设置物理交换机 MLAG 设置