问题

  • 无法访问主机。由于用户名或密码不正确,导致无法完成登录。
  • 传输节点应用任务失败,并显示错误节点已存在
  • 主机处于孤立状态。

原因

出现此问题的原因是,流量负载较大时出现争用情况。运行 API GET /api/v1/transport-nodes/<TN-UUID>/status 以查看传输节点的状态,在输出中,传输节点状态显示为“未知”且节点部署状态显示为失败

如果在启动 NSX 移除任务时未正确清理主机 TN,并且它因此在 NSX Manager 中仍处于已注册状态,则会发生此类情况。

在这种情况下,GET 传输节点 (GET transport node) API 和 GET 传输节点状态 (GET transport node status) API 将失败,但 GET 传输节点状态 (GET transport node state) API 将正常工作,并显示以下失败消息:无法卸载主机上的软件...。API 命令是 GET /api/v1/transport-nodes/<TN-UUID>/state

解决方案

  • 要修复失效条目的存在,必须强制从主机中移除NSX,并运行以下 API 以删除设置中的失效主机条目。
    1. (NSX Manager UI) 在主机页面上,选择强制删除选项,然后单击移除 NSX
    2. (API) 要强制删除 NSX,请运行以下 API:https://{{MPIP}}/api/v1/transport-nodes/<Transport-Node-UUID>?force=true&unprepare_host=false
    3. (API) 要移除失效条目,请运行以下 API:https://{{nsx-mgr-ip}}/api/v1/transport-nodes?action=clean_stale_entries