check-circle-line exclamation-circle-line close-line

VMware Tools 10.0.0 发行说明

更新时间:2017 年 6 月 21 日

VMware Tools | 2015 年 9 月 03 日 | 内部版本 3000743

查看本发行说明的补充和更新。

发行说明内容

本发行说明包含以下主题:

新增功能

VMware Tools 是一套可以提高虚拟机客户机操作系统性能并改善虚拟机管理的实用工具。阅读以下内容,了解此版本中的新功能和增强功能:

  • 通用版本控制:基础架构进行了更改,可以报告 VMware Tools 操作系统特定包的真实版本。这些更改将依赖于主机支持。
  • 通用代理框架:对于客户虚拟机内的代理,通用代理框架 (Common Agent Framework, CAF) 提供了简化其安全、有效的管理工作所需的基本服务。
  • Linux 上的静止快照增强:静止快照操作的可靠性得到了增强。vmtoolsd 服务支持在客户机 I/O 静止时缓存日志消息。vmbackup 插件得到了增强,可以使用单独的线程来静止客户机操作系统,从而避免由于客户机的 I/O 负载过重导致超时问题。
  • 共享文件夹:对于内核版本为 4.0.0 及更高版本的 Linux 分发包,可以使用基于 FUSE 的全新“共享文件夹”客户端代替内核模式客户端。
  • ESXi 可维护性:默认的 vmtoolsd 日志记录指向某个文件,而非 Syslog 或事件查看器。Windows 上的 VMwareToolboxCmd.exe 和 Linux 上的 vmware-toolbox-cmd 得到了增强,可以更改 vmtoolsd 日志记录级别。
  • GuestInfo 增强:插件得到了增强,可以报告超过 64 个来自客户机的 IP 地址。这些增强功能将依赖于主机支持。
  • TLS 支持:VMware Tools 10.0.0 支持 SSLv3、TLSv1、TLSv1.1 和 TLSv1.2。
  • OpenSSL:OpenSSL 已更新到版本 1.0.1p。

开始之前

有关升级至 ESXi 5.5 Update 3b 或更高版本的重要说明

如果使用的是较低版本的 Horizon View Agent,有关将 ESXi 主机升级至 ESXi 5.5 Update 3b 或者 ESXi 6.0 Update 1 或更高版本时不兼容问题的解决方法以及一般准则,请参阅以下知识库文章:

通过 ESXi 5.5 Update 3b 或更高版本中托管的 Horizon View Agent 5.3.5 或更低版本连接到 View 桌面失败,且出现黑屏。
通过 ESXi 5.5 Update 3b 或更高版本中托管的 Horizon View Agent 6.0.x 或 6.1.x 连接到 View 桌面失败,且出现黑屏。
通过 ESXi 6.0 Update 1 或更高版本中托管的 Horizon View Agent 6.1.x 连接到 View 桌面失败,且出现黑屏。

国际化

VMware Tools 10.0.0 提供以下语言的版本:

  • 英语
  • 法语
  • 德语
  • 西班牙语
  • 意大利语
  • 日语
  • 韩语
  • 简体中文
  • 繁体中文

兼容性

VMware Tools 10.0.0 与受支持版本的 VMware vSphere ESXi 5.0 及更高版本、VMware Workstation 12.0 和 VMware Fusion 8.0 均兼容。有关详细信息,请参见 VMware 兼容性指南

客户机操作系统自定义支持

客户机操作系统自定义支持列表中详细介绍了支持自定义的客户机操作系统。

此版本的安装和升级

可以从产品下载页面下载 VMware Tools。

可以从 http://packages.vmware.com/tools/releases/index.html 下载 VMware Tools 操作系统特定包。

VMware Tools 的安装步骤取决于您的 VMware 产品和您安装的客户机操作系统。有关在大多数 VMware 产品中安装 VMware Tools 的常规步骤,请参见《常规 VMware Tools 安装说明》(1014294)《VMware Tools 安装和配置指南》

有关安装、升级和配置 VMware Tools 的具体说明,请参见 VMware 文档页面。

产品支持注意事项

当与 VMware Workstation 12.0、VMware Fusion 8.0 和将来某个版本的 VMware vSphere(其中的虚拟设备支持所需的功能)一起使用时,VMware Tools 10.0.0 可以支持 Windows 客户机上的 DirectX 10.0 和 OpenGL 3.3。

已知问题

已知问题如下:

  • 尝试连接到 View 桌面导致出现黑屏
    在将 VMware vSphere 升级至版本 6.0 Update 1 和将 VMware Tools 升级至最新的 View 桌面版本时,如果安装较低版本的 View Agent,您可能会在 View Agent PCOIP 日志中看到与下面内容类似的错误,该日志位于 DriveLetter:\ProgramData\VMware\VDM\logs
    LVL:0 RC:0 IMG_FRONTEND :Calling open display in Tera2 mode.
    LVL:0 RC:0 IMG_FRONTEND :configure_displays: 1 display(s) initially reported!
    LVL:2 RC:0 IMG_FRONTEND :configure_displays: (1) single display[0]: pos:(0, 0) w: 1024, h: 768, bpp: 32
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--* id: 48 mon_id: 0 pos: (0,0) w: 1024 h: 768
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--bpp: 32 --pitch: 4096 --map size: 1552 --fb size: 3145728
    LVL:0 RC:0 IMG_FRONTEND :configure_display[0]--rot: 0 --pre-rot pitch: 4096 --frontend motion is enabled
    LVL:0 RC:0 EXTERN :svga_devtap ==> second render failed: 0xc0000008
    LVL:0 RC:0 EXTERN :svga_devtap ==> Error: screen dma failed
    LVL:0 RC:0 IMG_FRONTEND :flip_frame_buffer: General flip error [1 results for 1 displays]: [4001, 0]
    LVL:0 RC:-500 IMG_FRONTEND :open_displays(): Flip error in open display first flip.
  • 出现这种问题是因为随 VMware Tools 安装的视频驱动程序与较低版本的 View Agent 不兼容。

    解决方法:要解决此问题,请视情况按照下列建议之一操作。

    • 建议不要为使用版本低于 Horizon View Agent 6.2 的用户安装 VMware Tools 10.0.0 或更高版本。
    • 安装最新版本的 Horizon View Agent 6.2。或者,如果无法安装 View Agent 6.2,可删除现有的 View Agent 和 VMware Tools,安装较低版本的 VMware Tools 后再安装所需的 View Agent。

  • 在 OS X 10.10 上安装 VMware Tools 会失败
    在 OS X 10.10 上安装 VMware Tools 会失败,并出现如下的错误:

  • “安装失败 (The installation failed)”

    解决方法:在安装 VMware Tools 10.0.0 之前,请先卸载 VMware Tools。

  • IPv6 地址的状态显示为“unknown”
    vim-cmd 中 IPv6 地址的状态显示为“unknown”,即使该地址有效也是如此。
  • 解决方法:无。

  • 主机与客户机系统之间的文本复制和粘贴操作会失败
    如果文本大小达到或超过 50 KB,则主机与客户机系统之间的文本复制和粘贴操作会失败。
  • 解决方法:减小复制和粘贴的文本大小。

  • 在 Windows 2000 Professional SP4 上安装 VMware Tools 会失败并出现错误
    在 Windows 2000 Professional SP4 上将 ThinPrint 驱动程序与 VMware Tools 10.0.0 一起安装会失败,并出现错误提示。

  • 解决方法:要解决此问题,请视情况按照下列建议之一操作。

    • 对于已安装 ThinPrint 的用户,建议不要将 VMware Tools 更新至版本 10.0.0。
    • 对于尚未安装 ThinPrint 的用户,建议不要将 ThinPrint 与 VMware Tools 10.0.0 一起安装。
  • 在 Linux 客户机上安装 VMware Tools 时使用 clobber 选项可能会失败
    在引导虚拟机的过程中,在 Linux 客户机上安装 VMware Tools 时使用 clobber 选项可能会失败。

    解决方法:要解决此问题,请使用 Linux 内核提供的上游驱动程序。

  • guestinfo 中的 ipAddress 字段定义不明确
    ipAddress 字段的定义是“为客户机操作系统分配的主 IP 地址(如果已知)”。

  • 解决方法:对于 Linux,此上下文中的 ipAddress 字段的定义为“VMware Tools 获取的第一个 IP 地址”。

  • 安装客户机操作系统后,在 VMware Fusion 中重新安装 VMware Tools 的选项被禁用
    在安装 Windows XP SP3 和 SUSE Linux Enterprise Desktop 12 客户机操作系统后,VMware Fusion 中的菜单选项“重新安装 VMware Tools”被禁用。
  • 注意:此问题可能只会出现在部分主机(而非所有主机)上。

    解决方法:要解决此问题,请关闭虚拟机,然后重新启动。

  • 在 FreeBSD 10.x 虚拟机上安装 VMware Tools 10.0.0 后,可能无法从 Workstation Pro 或 Fusion 界面正常关闭虚拟机
    在 FreeBSD 10.x 虚拟机上安装 VMware Tools 10.0.0 后,VMware Tools 服务 vmtoolsd 可能无法启动。vmtoolsd 在后台运行,负责执行各种操作。可能会遇到的症状是也许无法从 Workstation Pro 或 Fusion 界面按预期关闭客户机操作系统。例如,首次尝试关闭客户机可能会失败,而从该界面进行第二次尝试会转换为关闭虚拟机电源的操作,而不是正常关闭。

    解决方法:使用旧版本 Workstation Pro 或 Fusion 附带的 VMware Tools 版本。