本主题提供了关于 VMware Tools 的常见问题解答。

  • 我的操作系统可以在不使用 VMware Tools 的情况下运行吗?

    尽管客户机操作系统在不使用 VMware Tools 的情况下也可以运行,但是要使用最新的功能和更新,务必在客户机操作系统中运行最新版本的 VMware Tools。可以将虚拟机配置为在每次打开电源时自动检查和应用 VMware Tools 升级。

  • VMware Tools 采用何种方式发布?

    ISO(包含安装程序):这些文件随产品一起打包并可通过多种方式安装,具体采用哪种安装方式取决于 VMware 产品以及虚拟机中安装的客户机操作系统。有关详细信息,请参见安装 VMware Tools 部分。VMware Tools 为以下每种支持的客户机操作系统提供了不同的 ISO 文件:Mac OS X、Windows、Linux、NetWare、Solaris 和 FreeBSD。

    特定于操作系统的软件包 (OSP):可下载的二进制软件包,由 VMware 为特定版本的 Linux 分发包构建和提供。OSP 通常可用于较旧的版本,例如 RHEL 6。最新版本的 Linux 包含 Open VM Tools,从而无需单独安装 OSP。要下载 OSP 并查找重要信息和说明,请参见 VMware Tools 特定于操作系统的软件包 (OSP)。有关支持的客户机操作系统列表,请参见《VMware 兼容性指南》

    open-vm-tools (OVT):这是 VMware Tools 的开源实现,专供 Linux 分发包维护人员和虚拟设备供应商使用。OVT 通常包含在当前版本的通用 Linux 分发包中,允许管理员随其他 Linux 软件包一起轻松安装和更新 VMware Tools。有关详细信息,请参见知识库文章《对 Open VM Tools 的 VMware 支持 (2073803)》

  • open-vm-tools 支持哪些操作系统?
    • Red Hat Enterprise Linux 7.0 及更高版本
    • SUSE Linux Enterprise 12 及更高版本
    • Ubuntu 14.04 及更高版本
    • CentOS 7 及更高版本
    • FreeBSD 10.3、10.4 和 11.1
    • Debian 7.x 及更高版本
    • Oracle Linux 7 及更高版本
    • Fedora 19 及更高版本
    • openSUSE 11.x 及更高版本
  • 是否有可用的 VMware Tools VIB?

    脱机包中包含 VMware Tools VIB,可使用 vSphere Update Manager 在 vSphere 5.5.x、6.0.x 和 6.5.x 上安装这些脱机包。脱机包在 10.2.0 及更高版本中受支持。