用户无法从 VMware Identity Manager 用户门户中启动 Horizon 7 或 Horizon 6 应用程序或桌面。

问题

用户无法从 VMware Identity Manager 用户门户中启动 Horizon 7 或 Horizon 6 应用程序或桌面,并在用户界面中显示以下错误:

启动资源时出错。请联系您的 IT 管理员 (Error launching resource. Please contact your IT Administrator)。

原因

如果 Horizon 连接服务器实例上的 SAML 元数据在上次同步后已过期,则可能会出现该错误。

解决方案

  1. VMware Identity Manager 控制台中,单击目录 > 虚拟应用程序集合选项卡。
  2. 选择 Horizon 虚拟应用程序集合,然后单击同步以将 Horizon 资源重新同步到 VMware Identity Manager
  3. 单击编辑以编辑虚拟应用程序集合,在向导中单击下一步,直到显示最后一页,然后单击保存
    重要事项: 如果您添加或更新了网络范围或策略,此步骤会非常重要。您必须再次保存虚拟应用程序集合以使更改生效。