VMware Identity Manager 需要使用 Java Runtime Environment (JRE)。

所需的 JRE 版本与 VMware Identity Manager 安装程序打包在一起。在升级 VMware Identity Manager 时,将提示您还要升级 JRE 版本。

如果要在任何其他时间升级 VMware Identity Manager 服务器上的 JRE,请执行以下步骤以确保 VMware Identity Manager 服务在 JRE 升级后继续正常工作。

注: 如果 JRE 是自动升级的,请在升级后执行步骤 3 至 4。

过程

  1. 停止 VMware IDM、Elasticsearch 和 VMware IDM 证书代理服务。
  2. 安装新的 JRE 版本。
  3. 更新 JAVA_HOME 环境变量以指向新的 JRE。
  4. 重新启动 VMware IDM、Elasticsearch 和 VMware IDM 证书代理服务。