您可以将 Citrix 部署与 Workspace ONE Access(以前称为 VMware Identity Manager)集成在一起,以便为 Workspace ONE 用户提供对 Citrix 发布的资源的访问。Citrix 发布的资源包括 Citrix XenApp 和 XenDesktop 服务器场中的应用程序和桌面。桌面也称为 Citrix 发布的交付组。

您可以在 Citrix 管理界面中管理 Citrix 发布的应用程序和桌面。您还可以在 Citrix 界面中设置用户和组授权,而不是在 Workspace ONE Access 服务中设置。在与 Citrix 服务器场集成之前,您必须将这些用户和组从 Active Directory 同步到 Workspace ONE Access 服务。

要将 Citrix 服务器场与 Workspace ONE Access 集成在一起,需在 Workspace ONE Access 控制台中创建一个或多个虚拟应用程序集合。这些收集包含服务器场的配置信息以及同步设置。

您可以为每个集合设置同步计划,以定期将 Citrix 服务器场中的资源和授权同步到 Workspace ONE Access 服务。

在集成 Citrix 服务器场后,您可以在 Workspace ONE Access 控制台中查看同步的资源和授权。您还可以编辑 ICA 会话设置,例如,控制分辨率或压缩的设置。您可以在全局范围内为 Workspace ONE Access 目录中的所有 Citrix 资源配置设置,或者也可以为单个 Citrix 资源配置设置。

最终用户可以从 Workspace ONE 门户或应用程序启动 Citrix 发布的应用程序和桌面。他们需要在其系统和设备上安装 Citrix Receiver,以便访问授权他们使用的资源。

注: Workspace ONE Access 支持包含 Citrix NetScaler 的 Citrix 部署。

支持的版本

  • Workspace ONE Access 支持 Citrix XenApp 6.0 和 6.5、XenApp 和 XenDesktop 7.x 以及 Citrix 虚拟应用程序和桌面 7 1808。
    注:Workspace ONE Access 3.3 开始,不再支持 XenApp 5.x。
  • Workspace ONE Access 支持 Citrix StoreFront API 2.6 及更高版本。
  • Integration Broker(与 Citrix 服务器场通信的 Workspace ONE Access 组件)支持的操作系统为 Windows Server 2008 R2、Windows Server 2012、Windows Server 2012 R2 和 Windows Server 2016。
  • Integration Broker 版本要求:
    Workspace ONE Access (VMware Identity Manager) 服务或连接器版本 支持的 Integration Broker 版本
    VMware Identity Manager 19.03 19.03
    VMware Identity Manager Connector 19.03.0.0 19.03
    VMware Identity Manager 3.3 3.3
    VMware Identity Manager Connector 2018.8.1.0(随 VMware Identity Manager 3.3 发行的 Connector) 3.3
    VMware Identity Manager 3.2 3.2
    VMware Identity Manager Connector 2018.1.1.0(随 VMware Identity Manager 3.2 发行的 Connector) 3.2
    VMware Identity Manager 3.1 3.1
    VMware Identity Manager Connector 2017.12.1.0(随 VMware Identity Manager 3.1 发行的 Connector) 3.1
    VMware Identity Manager 3.0 3.0
    VMware Identity Manager Connector 2017.8.1.0(随 VMware Identity Manager 3.0 发行的 Connector) 3.0
    VMware Identity Manager 2.9.1 或更低版本 2.9.1 或更低版本
    VMware Identity Manager Connector 2.9.1 或更低版本 2.9.1 或更低版本
    注: 要使用 Citrix StoreFront API,需要使用 Integration Broker 2.9.1 或更高版本。要使用 XenApp 或 XenDesktop 7.x,需要使用 Integration Broker 2.6 或更高版本。要使用 NetScaler 功能,需要使用 Integration Broker 2.4 或更高版本。
注: 建议使用 Workspace ONE Access 及其组件的最新可用版本。

支持的身份验证方法

Workspace ONE Access 仅在 XenApp 服务器或 NetScaler 服务器上支持用户名和密码身份验证。它不支持其他身份验证方法,例如:
  • 智能卡
  • HTML 5
  • 双因素身份验证
  • SAML 身份验证 (Citrix FAS)

支持的功能

Workspace ONE Access 支持以下 XenApp 和 XenDesktop 功能。

  • 使用 Citrix StoreFront API 2.6 及更高版本启动应用程序和桌面
  • 应用程序组功能

    Workspace ONE Access 支持 XenApp 和 XenDesktop 7.9 中引入的应用程序组功能。应用程序组是应用程序和桌面的逻辑分组,可以在应用程序组级别提供授权。

  • 使用 NetScaler 进行外部启动
  • 在 XenApp 和 XenDesktop 服务器上禁用应用程序

    如果管理员在 XenApp 或 XenDesktop 服务器上禁用了某个应用程序,则该应用程序在 Workspace ONE Access 中将处于隐藏状态。

  • 限制应用程序的可见性

    此功能可设置应用程序的可见性。Workspace ONE Access 采用在应用程序级别设置的授权。

  • 对整个交付组显示应用程序

    在 XenApp 和 XenDesktop 中,可将应用程序的可见性设置为对整个交付组显示此应用程序。此应用程序将继承交付组的授权。

  • 桌面级别的授权

    Workspace ONE Access 采用在桌面级别为桌面设置的授权。

  • 静态桌面同步和启动

    可以从 Workspace ONE Access 同步和启动在 XenApp 和 XenDesktop 中配置的静态桌面。