Workspace ONE® Access™(以前称为 VMware Identity Manager™)提供了从 Workspace ONE Access Connector 版本 19.03 和 19.03.0.1 到版本 22.05 的迁移路径。迁移过程包括安装新的 22.05 Connector,并将现有目录和虚拟应用程序集合迁移到新连接器。您无法直接将 Connector 版本 19.03 或 19.03.0.1 升级到版本 22.05。

要迁移到 22.05 Connector,您需要迁移所有目录和支持的虚拟应用程序集合。迁移目录时,将迁移所有数据,包括身份验证方法和身份提供程序。在迁移虚拟应用程序集合时,将迁移虚拟应用程序配置。迁移是一次性过程,因此必须将目录和虚拟应用集合一起迁移。

重要事项: Workspace ONE Access Connector 22.05 仅与 Workspace ONE Access 云部署版本兼容。它与内部部署的 Workspace ONE Access 虚拟设备不兼容。
注: 您可以将 Workspace ONE Access Connector 版本 21.08. x、20.10. x 和 20.01. x 升级到版本 22.05。请参阅 《升级到 VMware Workspace ONE Access Connector 21.08》指南。

关于 Workspace ONE Access Connector 22.05

Workspace ONE Access Connector 22.05 是一个企业服务集合,可以在 Windows 服务器上单独或一起安装这些服务。其中包括以下服务:

  • 目录同步服务:将 Active Directory 或 LDAP 目录中的用户同步到 Workspace ONE Access 服务
  • 用户身份验证服务:提供基于连接器的身份验证方法,包括密码(云部署)、RSA SecurID(云部署)和 RADIUS(云部署)
  • Kerberos 身份验证服务:为内部用户提供 Kerberos 身份验证
  • 虚拟应用程序服务:将虚拟应用程序从 VMware Horizon®、具有单容器代理的 Horizon Cloud Service on Microsoft Azure 或 Horizon Cloud Service on IBM Cloud 和 Citrix® 部署同步到 Workspace ONE Access 服务
    重要事项: Workspace ONE Access Connector 22.05 不支持与 ThinApp 打包应用程序集成。

    与具有 Universal Broker 的 Horizon Cloud Service on Microsoft Azure 的集成是从 Horizon Cloud 管理控制台中配置的,不需要使用虚拟应用程序服务。

Workspace ONE Access 服务和设备的兼容性

Workspace ONE Access Connector 22.05 仅与 Workspace ONE Access 云部署版本兼容。它与内部部署的 Workspace ONE Access 虚拟设备不兼容。

联邦信息处理标准 (FIPS) 模式

Workspace ONE Access Connector 22.05 可以使用符合 FIPS 140-2 的算法执行加密操作。仅新的连接器安装支持 FIPS 模式。在升级或迁移到 22.05 Connector 时,不支持此模式。
重要事项: 在迁移过程中,当您安装新的 22.05 Connector 时,在安装程序的“指定配置文件”页面上将显示用于启用 FIPS 模式的选项。确保未选择 启用 FIPS 选项。

有关 FIPS 模式的更多信息,请参阅《安装 VMware Workspace ONE Access Connector 22.05》中的 Workspace ONE Access Connector 22.05 和 FIPS 模式

迁移到 Connector 22.05 的用例

Workspace ONE Access Connector 版本 19.03 或 19.03.0.1 迁移到版本 22.05 适用于某些用例。请按照以下准则以确定是否迁移到版本 22.05。

  • 如果您的部署包括 VMware Horizon 虚拟应用程序,您可以迁移到 Workspace ONE Access Connector 22.05。22.05 Connector 支持与 Horizon 8 和 Horizon 7 的集成。
    小心: 如果您使用早期版本的 Horizon,请不要迁移到 22.05 Connector。
  • 如果您的部署包括 Citrix 虚拟应用程序,在以下情况下,您可以迁移到 Workspace ONE Access Connector 22.05:
    • 您使用以下 Citrix 版本之一:Citrix Virtual Apps and Desktops 7 1912 LTSR、XenApp and XenDesktop 7.15 LTSR 或 XenApp and XenDesktop 7.6 LTSR。
    • 您使用的是 Citrix StoreFront。
    小心: 如果您使用早期版本的 Citrix 或使用 Citrix Web Interface SDK,请不要迁移到 22.05 Connector。
  • 如果您的部署包括Horizon Cloud Service虚拟应用程序,请遵循以下准则:
    • 如果当前安装包含具有单容器代理的 Horizon Cloud Service on Microsoft Azure 或 Horizon Cloud Service on IBM Cloud 的虚拟应用程序集合,则可以迁移到 Workspace ONE Access 22.05。22.05 Connector 支持此集成。
    • 但是,如果您计划将 Horizon Cloud 环境转换为具有 Universal Broker 的 Horizon Cloud Service on Microsoft Azure,则无需在 Workspace ONE Access 中迁移虚拟应用程序集合。Workspace ONE Access 与 Universal Broker 环境的集成不需要使用虚拟应用程序集合,也不需要使用 Workspace ONE Access Connector 的虚拟应用程序服务组件。在设置与 Universal Broker 环境的集成时,必须在 Workspace ONE Access 中删除现有的虚拟应用程序集合。

      有关设置与 Universal Broker 环境的集成的信息,请参阅 Horizon Cloud Service 文档:具有 Universal Broker 的 Horizon Cloud 环境 - 将租户与 Workspace ONE Access 和 Intelligent Hub 服务集成

  • Workspace ONE Access Connector 22.05 不支持 ThinApp 集成。