升级失败,并显示“需要更新证书身份验证配置”错误。

问题

当您尝试升级到 VMware Identity Manager 3.3.4 时,出现以下错误消息,且升级中止。

在升级之前,需要更新租户 <tenantName> 的证书身份验证配置。预更新检查失败,正在中止升级 (Certificate auth configuration update required for tenant <tenantName> prior to upgrade. Pre-update check failed, aborting upgrade)。

原因

如果最新添加或更新的 CertificateAuthAdapter 的证书低于 3.0 版,则会出现此问题。

解决方案

  1. 登录到 VMware Identity Manager 控制台。
  2. 导航到身份和访问管理 > 设置
  3. 连接器页面中,单击工作线程列中的链接。
  4. 单击身份验证适配器选项卡,然后单击 CertificateAuthAdapter
  5. 上载的 CA 证书部分中,单击红色的 X 图标以移除证书。
  6. 单击保存
  7. 根 CA 证书和中间 CA 证书部分中,单击选择文件以重新添加证书。
  8. 单击保存
  9. 返回到虚拟设备控制台,然后再次运行升级命令。