Workspace ONE Access 中未显示 Citrix 授权。

问题

在 Citrix 服务器上设置了对应用程序或交付组的授权,但是 Workspace ONE Access 中却未显示这些授权。

原因

有权访问应用程序或交付组的用户和组可能未同步到 Workspace ONE Access

解决方案

请确保将用户和组同步到 Workspace ONE Access
  1. 登录到 Citrix 管理控制台,然后找到没有任何授权的应用程序。
  2. 记下 Citrix 管理控制台中有权启动该应用程序的 Active Directory 用户和组。
  3. 登录到 Workspace ONE Access 控制台,导航到帐户 > 用户帐户 > 用户组页面,然后确认这些用户和组显示在列表中。
  4. 如果 Workspace ONE Access 中存在这些用户和组,请再次从资源 > 虚拟应用程序集合页面同步 Citrix 资源。
    注: 在同步 Citrix 资源之前, Workspace ONE Access 中必须存在这些用户和组。如果这些用户和组不存在,也会运行同步,但不会更新授权。
  5. 如果 Workspace ONE Access 中不存在这些用户和组,请执行以下操作。
    1. 检查这些用户和组在 Active Directory 中的位置(使用“Active Directory 用户和计算机”管理单元)。
    2. Workspace ONE Access 控制台中,在目录的同步设置页中更新这些用户和组的 AD 同步 DN。
    3. 当这些用户和组显示在 Workspace ONE Access 控制台中后,请重新同步 Citrix 资源。

    同步完成后,Workspace ONE Access 中即会显示相应授权。