您可以通过在 vRealize Operations Cloud 中安装和配置管理包来扩展 vRealize Operations Cloud 的监控功能,以便连接到环境中的外部数据源并从中分析数据。连接之后,即可使用 vRealize Operations Cloud 监控和管理环境中的对象。

管理包可能只是与数据源的连接,也可能包括预定义的仪表板、小组件、警示和视图。

解决方案可以包括云帐户、其他帐户、仪表板、报告、警示和其他内容。云帐户和其他帐户包含适配器并使用 vRealize Operations Cloud 管理与其他产品、应用程序和功能的通信与集成。安装了管理包并配置了适配器后,您可以使用 vRealize Operations Cloud 分析和警示工具来管理环境中的对象。

VMware 解决方案包括用于存储设备、Log Insight、NSX for vSphere、网络设备和 VCM 的适配器。第三方解决方案包括 AWS、SCOM、EMC Smarts 等。

其他管理包(如 VMware Management Pack for NSX for vSphere)可以从存储库页面作为管理包添加到 vRealize Operations Cloud。要下载 VMware Management Pack 和其他第三方解决方案,请访问 VMware Solution Exchange:https://marketplace.vmware.com/vsx/

vRealize Operations Cloud 包含预安装的管理包。这些解决方案是在安装 vRealize Operations Cloud 时安装的,无法停用。管理包如下所示:
  • VMware vSphere
  • VMware vRealize Log Insight
  • VMware vRealize 评估
  • VMware vSAN
  • vRealize Operations Service Discovery Management Pack
  • VMware vRealize Automation 8.x
  • VMware Management Pack for AWS
  • VMware Management Pack for Microsoft Azure
  • VMware vRealize Operations Management Pack for NSX-T
  • VMware vRealize Operations Management Pack for VMware Cloud on AWS
  • VMware vRealize Network Insight

vRealize Operations Cloud 还包括与 vRealize Operations Cloud 捆绑在一起但未激活的管理包。您可以从存储库页面激活这些管理包。管理包如下所示:

  • 操作系统/远程服务监控
  • VMware vRealize Application Management Pack
  • VMware vRealize Automation 7.x
  • VMware vRealize Compliance Pack for PCI
  • VMware vRealize Compliance Pack for ISO
  • VMware vRealize Compliance Pack for HIPAA
  • VMware vRealize Compliance Pack for FISMA
  • VMware vRealize Compliance Pack for CIS
  • VMware vRealize Compliance Pack for DISA
  • VMware vRealize Ping

升级注意事项

如果升级 vRealize Operations Cloud,则将重新安装与 vRealize Operations Cloud 捆绑在一起的管理包。如果全新部署的 vRealize Operations Cloud,则只会安装并激活 VMware vSphere 和 vRealize Optimization Assessment,所有其他管理包预捆绑在一起,需要激活才能使用。

如果从早期版本的 vRealize Operations Cloud 进行升级,系统会将您的管理包文件复制到以日期和时间命名的文件夹中的 /usr/lib/vmware-vcops/user/plugins/.backup 文件中。在将数据迁移到新的 vRealize Operations Cloud 实例之前,必须再次配置适配器实例。如果您已自定义适配器,则您的适配器自定义不包括在迁移中,您必须重新配置自定义。

如果您将 vRealize Operations Cloud 中的管理包更新为较新版本,并且您已自定义适配器,则升级不会包含您的适配器自定义,您必须重新进行配置。