您可以配置虚拟机以自动更新 VMware Tools。

开始之前

  • 确认虚拟机上安装了 ESX/ESXi 3.5 或更高版本随附的 VMware Tools 版本。

  • 确认虚拟机驻留在 ESX/ESXi 3.5 或更高版本以及 vCenter Server 3.5 或更高版本上。

  • 确认虚拟机正在运行 ESX/ESXi 3.5 或更高版本以及 vCenter Server 3.5 或更高版本支持的 Linux 或 Windows 客户机操作系统。

关于此任务

注:

具有 Solaris 或 NetWare 客户机操作系统的虚拟机不支持 VMware Tools 自动升级。

过程

  1. 右键单击虚拟机,然后单击编辑设置
  2. 单击选项选项卡,然后选择 VMware Tools
  3. 高级窗格中,选中在关闭再打开电源过程中检查并升级工具复选框。
  4. 单击确定保存更改并关闭对话框。

结果

下次打开虚拟机电源时,将检查 ESX/ESXi 主机是否具有更新版本的 VMware Tools。如果有,将安装更新版本,并重新启动客户机操作系统(如果需要)。