vSphere 5.1 及更高版本仅在具有特定配置的环境中支持 SR-IOV。某些 vSphere 功能在启用 SR-IOV 后会失效。

支持的配置

要在 vSphere 5.5 中使用 SR-IOV,您的环境必须满足多个配置要求。

表 1. 要使用 SR-IOV 所需支持的配置

组件

要求

vSphere

  • 配备 Intel 处理器的主机需要使用 ESXi 5.1 或更高版本。

  • ESXi 5.5 或更高版本中,配备 AMD 处理器的主机受 SR-IOV 支持。

物理主机

  • 必须与 ESXi 版本兼容。

  • 如果运行 ESXi 5.1,则必须配备 Intel 处理器,如果运行 ESXi 5.5 及更高版本,则必须配备 Intel 或 AMD 处理器。

  • 必须支持 I/O 内存管理单元 (IOMMU),并且必须在 BIOS 中启用 IOMMU。

  • 必须支持 SR-IOV,并且必须在 BIOS 中启用 SR-IOV。请联系服务器供应商以确定主机是否支持 SR-IOV。

物理网卡

  • 必须与 ESXi 版本兼容。

  • 根据服务器供应商提供的技术文档,必须支持用于主机和 SR-IOV。

  • 必须在固件中启用 SR-IOV。

对于物理网卡,在 ESXi 中使用 PF 驱动程序

  • 必须经过 VMware 的认证。

  • 必须安装在 ESXi 主机上。对于某些网卡,ESXi 版本提供默认驱动程序,而对于其他版本,必须下载并手动安装驱动程序。

客户机操作系统

根据网卡供应商提供的技术文档,必须受已安装的 ESXi 版本上的网卡支持。

客户机操作系统中使用 VF 驱动程序

  • 必须与网卡兼容。

  • 根据网卡供应商提供的技术文档,必须受客户机操作系统版本的支持。

  • 必须由 Microsoft WLK 或 WHCK 针对 Windows 虚拟机进行认证。

  • 必须安装在操作系统中。对于某些网卡,操作系统版本中包含默认驱动程序,而对于其他网卡,则必须从网卡供应商或主机供应商所提供的位置下载并安装驱动程序。

要确认物理主机和网卡是否与 ESXi 版本兼容,请参见《VMware 兼容性指南》

功能可用性

以下功能对配置了 SR-IOV 的虚拟机不可用:

  • vSphere vMotion

  • Storage vMotion

  • vShield

  • NetFlow

  • VXLAN 虚拟线路

  • vSphere High Availability

  • vSphere Fault Tolerance

  • vSphere DRS

  • vSphere DPM

  • 虚拟机挂起和恢复

  • 虚拟机快照

  • 用于直通虚拟功能的基于 MAC 的 VLAN

  • 热添加和删除虚拟设备、内存和 vCPU

  • 加入到群集环境

  • 使用 SR-IOV 直通的虚拟机网卡的网络统计信息

注:

如果在 vSphere Web Client 中尝试启用或配置使用 SR-IOV 的不受支持的功能,会导致环境中出现意外行为。

受支持的网卡

所有网卡必须具有支持 SR-IOV 的驱动程序和固件。某些网卡可能需要在固件上启用 SR-IOV。配置了 SR-IOV 的虚拟机支持以下网卡:

  • 基于 Intel 82599ES 10 GB 以太网控制器系列的产品 (Niantic)

  • 基于 Intel 以太网控制器 X540 系列的产品 (Twinville)

  • 基于 Intel 以太网控制器 X710 系列的产品 (Fortville)

  • 基于 Intel 以太网控制器 XL170 系列的产品 (Fortville)

  • Emulex OneConnect (BE3)

从 vSphere 5.0 及之前的版本升级

如果从 vSphere 5.0 或更早的版本升级到 vSphere 5.5 或更高的版本,则在为 vSphere 版本更新网卡驱动程序之前,无法取得 SR-IOV 支持。必须为网卡启用支持 SR-IOV 的固件和驱动程序,以使 SR-IOV 功能正常运行。

从 vSphere 5.1 升级

尽管在满足要求的 ESXi 5.1 主机上支持 SR-IOV,但您无法使用 vSphere Web Client 在这些主机上配置 SR-IOV。使用网卡驱动程序模块的 max_vfs 参数在这些主机上启用 SR-IOV。请参见使用 vSphere Web Client 中的主机配置文件或通过 ESXCLI 命令启用 SR-IOV

您也无法将 SR-IOV 直通适配器分配给此类主机上的虚拟机。该适配器可供与 ESXi 5.5 及更高版本兼容的虚拟机使用。虽然 vCenter Server 5.5 版本可能正在管理 ESXi 5.1 主机,但配置将与版本 5.1 中相同。必须将 PCI 设备添加到虚拟机硬件,并手动为该设备选择 VF。