主机可能包含第三方软件,如 Cisco Nexus 1000V VEM 或 EMC PowerPath 模块。要成功升级或迁移此类主机,必须在修复过程中使用自定义 ESXi 映像或删除第三方模块。

无法将第三方解决方案作为主机升级的一部分直接进行迁移。ESX/ESXi 4.x 与 ESXi 5.x 之间的架构更改以及 VIB 的向前不兼容性会导致丢失第三方组件,并可能导致系统不稳定。要完成此类迁移,您可以使用 ESXi Image Builder CLI 创建自定义 ISO 文件。有关使用第三方自定义进行升级的信息,请参见《vSphere 升级》文档。有关使用 ESXi Image Builder CLI 创建自定义 ISO 的信息,请参见《vSphere 安装和设置》文档

可以使用 Update Manager 修复向导,移除已安装的第三方解决方案。

ESXi 5.0、ESXi 5.1 主机和 ESXi 5.5 主机为二进制兼容。升级到 ESXi 5.5 之后,ESXi 5.0 和 ESXi 5.1 主机上的所有第三方软件模块将保持不变,而不管您是否已选择移除第三方模块。

如果要将 ESXi 5.0 或 ESXi 5.1 主机升级到 ESXi 5.5 主机,则主机上未包含在 ESXi 安装程序 ISO 中的受支持自定义 VIB 将会迁移。如果主机或升级 ISO 映像包含制造冲突和阻止升级的 VIB,则错误消息会指出冲突的 VIB。您可以删除该 VIB 并重新升级,或者使用 ESXi Image Builder CLI 创建一个可以解决该冲突的自定义 .iso

要在升级或迁移操作之前发现第三方软件潜在的问题,请根据升级基准扫描主机并查看“Update Manager 合规性”视图中的扫描消息。请参见Update Manager 中的主机升级扫描消息存在 Cisco Nexus 1000V 时的主机升级扫描消息