如果您熟悉 ESXi 版本 4.x 脚本式安装,则在执行脚本式 ESXi 安装或升级之前,请注意 ESXi 4.x 和 ESXi 5.x 脚本式安装和升级命令之间的差异。

ESXi 5.x 中,由于安装映像会在引导主机时直接加载到主机内存中,因此不需要在安装脚本中包含安装介质的位置。

除了脚本式安装外,ESXi 5.x 还支持脚本式升级。

以下摘要中记录了命令差异。

accepteulavmaccepteula

仅在 ESXi

autopart

已弃用并替换为 installupgradeinstallorupgrade

authauthconfig

ESXi 5.x 中不支持。

bootloader

ESXi 5.x 中不支持。

esxlocation

已弃用且不在 ESXi 中使用。

防火墙

ESXi 5.x 中不支持。

firewallport

ESXi 5.x 中不支持。

installinstallorupgradeupgrade

这些命令将替换已弃用的 autopart 命令。使用这些命令之一指定要分区的磁盘,并使用 part 命令创建 vmfs 数据存储。在 ESXi 5.x 中新增了对 installorupgradeupgrade 的支持。

serialnum

已在 ESXi 5.0.x 中弃用。在 ESXi 5.1 中支持。

vmserialnum

已在 ESXi 5.0.x 中弃用。在 ESXi 5.1 中支持。

时区

ESXi 5.x 中不支持。

virtualdisk

ESXi 5.x 中不支持。

zerombr

ESXi 5.x 中不支持。

%firstboot

ESXi 5.x 中不支持 --level 选项。

%packages

ESXi 5.x 中不支持。