vCenter Server 6.0 Update 3g | 2018 年 7 月 26 日 | ISO 内部版本 9146214

vCenter Server Appliance 6.0 Update 3g | 2018 年 7 月 26 日 | ISO 内部版本 9146214

vCenter Server Appliance 上的 vCenter Server 6.0 Update 3g 内部版本 9146216

Windows 上的 vCenter Server 6.0 Update 3g 内部版本 9121857

请查看发行说明以了解新增内容及更新。

发行说明内容

本发行说明包含以下主题:

新增功能

  • Pivotal tc Server 替换:Pivotal tc Server 现已替换为 Tomcat 8.5.24 和 Tomcat 8.5.23。
  • 更新了 Linux 客户机操作系统自定义中的时区:vCenter Server Linux 客户机操作系统自定义支持最新的时区。有关 Linux 客户机操作系统中时区变更和夏令时 (DST) 变更的详细信息,请参见互联网号码分配局 (IANA) 提供的时区数据库
  • 更新了 Windows 客户机操作系统自定义中的时区:vCenter Server Windows 客户机操作系统自定义支持最新的时区。有关 Windows 客户机操作系统中时区变更和夏令时 (DST) 变更的详细信息,请参见 Microsoft 知识库文章 3182203、Microsoft 知识库文章 4015193 和 Microsoft 知识库文章 4012864
  • TLS 支持:vCenter Server 6.0 Update 3g 支持 TLS 版本 1.2,可建立到 Microsoft SQL Server 的加密连接。有关详细信息,请参见 VMware 知识库文章 2149745
  • 外部数据库支持:vCenter Server 6.0 Update 3g 支持 Microsoft SQL Server 2014 Service Pack 2、SQL Server 2016、SQL 2016 Service Pack 1 和 SQL Server 2012 Service Pack 4。

vCenter Server 6.0 的早期版本

有关国际化、兼容性、安装和升级以及产品支持注意事项的说明,请参见 VMware vCenter Server 6.0 Update 3 发行说明

本版本中包含的修补程序

vCenter Server 6.0 Update 3g 提供以下修补程序。有关下载修补程序的详细信息,请参见 VMware Patch 下载中心

从 vCenter Server 6.0 Update 3g 开始,不支持适用于 vCenter Server Applicance 的第三方 (TP.iso) 修补程序包含第三方产品修复。

适用于 VMware vCenter Server 6.0 Update 3g 的安全修补程序

安全修复(例如:JRE)。此修补程序对适用于 Windows 的 vCenter Server、适用于 Windows 的 Platform Services Controller 和 vSphere Update Manager 适用。

针对适用于 Windows 的 vCenter Server 和 Platform Services Controller

下载文件名称 VMware-VIMPatch-6.0.0-8814879-20180726.iso
内部版本 8814879
下载大小 87.4 MB
md5sum 083032b4f3ed92bc696aad959eff88ba
sha1checksum 0758851e576f5045debfacb90bcac757981e7721

以下 vCenter Server 组件依赖于 JRE,并且必须安装修补程序:

  • Platform Services Controller
  • vSphere Update Manager
  • vCenter Server

下载和安装

可通过转到 VMware Patch 下载中心并从按产品搜索下拉菜单中选择 VC 来下载此修补程序。 

  1. VMware-VIMPatch-6.0.0-8814879-20180726.iso 挂载到已安装 vCenter Server 组件的系统中。  
  2. 双击 ISO_mount_directory/autorun.exe.
  3. 在“vCenter Server Java 组件更新”向导中,单击全部修补

适用于 VMware vCenter Server Appliance 6.0 Update 3g 的完整修补程序

适用于 vCenter Server Appliance 6.0 的产品修补程序包含 VMware 软件修复、安全修复和第三方产品修复(例如:JRE)。

此修补程序适用于 vCenter Server Appliance 和 Platform Services Controller Appliance。

注意:从 vCenter Server 6.0 Update 3g 开始,不支持适用于 vCenter Server Applicance 的第三方 (TP.iso) 修补程序包含第三方产品修复。

针对 vCenter Server 和 Platform Services Controller Appliance

下载文件名称 VMware-vCenter-Server-Appliance-6.0.0.30700-9146216-patch-FP.iso
内部版本 9146216
下载大小 1806.0 MB
md5sum c9690a41089a2a2249cabc156ad2efb5
sha1checksum b05814733613244ab8085ac4bd7956a18e1b53c5

下载和安装

可通过转到 VMware Patch 下载中心并从按产品搜索下拉菜单中选择 VC 来下载此修补程序。

  1. VMware-vCenter-Server-Appliance-6.0.0.30700-9146216-patch-FP.iso 文件附加到 vCenter Server Appliance CD 或 DVD 驱动器。
  2. 以 root 身份登录到设备 shell 并运行以下命令:
    • 转储 ISO:

      software-packages stage --iso

    • 查看已转储的内容:

      software-packages list --staged

    • 安装已转储的 RPM:

      software-packages install --staged

有关修补 vCenter Server Appliance 的详细信息,请参见修补 vCenter Server Appliance

有关转储修补程序的详细信息,请参见将修补程序转储到 vCenter Server Appliance

有关安装修补程序的详细信息,请参见安装 vCenter Server Appliance 修补程序

有关此修补程序中解决的问题,请参见已解决的问题部分。

有关使用设备管理界面进行修补的详细信息,请参见使用设备管理界面修补 vCenter Server Appliance

此版本的升级说明

重要信息:不支持从 vCenter Server 6.0 Update 3g 到 vCenter Server 6.5 和 6.7 的升级和迁移路径。

已解决的问题

已解决的问题分为以下几组。

安装问题
  • 在使用 Cisco Nexus N1K VEM 驱动程序的主机上,有状态安装可能会失败

    在使用 Cisco Nexus N1K VEM 驱动程序的配置中创建暂存分区时有状态安装可能会失败。n1k-vem 服务可能会在有状态安装完成前停止,并在安装后启动以应用主机配置文件。 

    本版本已解决该问题。

其他问题
  • 在备份操作期间创建快照需要很长时间才能完成,且 vCenter Server 停止显示有关清单中对象的事件数据

    在需要创建快照的备份操作期间,如果任务工作流中要发布事件数据,则可能需要很长时间才能完成。vCenter Server 会停止显示有关清单中对象的事件数据。

    本版本已解决该问题。

  • SNMP 始终显示 vCenter Server Appliance 的 CPU 和内存利用率为 100%

    如果使用 snmpwalk 命令查询 vCenter Server Appliance 的 CPU 和内存利用率,SNMP 可能始终报告 100%,即使实际利用率较低也是如此。

    本版本已解决该问题。 

  • 警报可能不会对状态为“未设置”的触发器作出响应

    如果使用 vSphere Web Client 设置警报并使触发器保持“未设置”状态,则此类警报可能不会提示任何操作。您可能会看到以下错误消息:vSphere Client 中出现内部错误。详细信息: 提供的警报状态无效 (The provided alarm status is invalid)。

    本版本已解决该问题。

  • 无法将 ESXi 主机置于空的增强型 vMotion 兼容性 (EVC) 群集中,即使主机满足要求也是如此

    如果主机未针对客户机操作系统应用管理程序协助的客户机缓解措施,将其添加到空的 EVC 群集可能失败,因为修补程序包含新的 CPU 功能。

    本版本已解决该问题。

  • 第三方陷阱接收方可能会拒绝 vCenter Server Appliance 中 497 天之前的陷阱

    第三方陷阱接收方可能会拒绝 vCenter Server Appliance 中 497 天之前的陷阱,因为此时参数跟踪时间超过了四字节限制。

    本版本已解决该问题。

网络连接问题
  • 取消虚拟机克隆后,虚拟机目录会继续存在

    克隆虚拟机的过程结束后,vCenter Server 可能不移除虚拟机目录中的端口文件目录 (.dvsData)。因此,虚拟机目录继续存在。

    本版本已解决该问题。

  • 在导入 VMware vSphere Distributed Switch 配置的过程中,链路聚合组 (LAG) 可能会丢失

    如果导入具有许多 LAG 的 vSphere Distributed Switch (VDS) 配置,则 vCenter Server 守护进程 vpxd 可能无法将对应的 LAG 信息插入到 vCenter Server 数据库。因此,在重新启动 vpxd 后可能缺少一些 LAG。

    本版本已解决该问题。如果此问题已经发生,请先删除 VDS 配置,然后再重新导入配置,或者手动创建缺少的 LAG。

  • 在导入临时端口组时,使用 VMware vSphere vMotion 迁移虚拟机可能会失败

    如果导入临时端口组或具有此类组的 VDS 实例,则使用 vSphere vMotion 迁移虚拟机可能会失败,因为在迁移后端口可能不存在。您可能会看到类似错误:出现常规系统错误: vim.fault.NotFound (A general system error occurred: vim.fault.NotFound)

    本版本已解决该问题。遇到此问题时,必须在迁移后先删除导入的临时端口组或具有此类端口组的 VDS,然后重新导入它们。

  • 由于 LAG 数据已过期,重新启动 vpxd 后,vSphere Web Client 可能会在 VDS 拓扑中显示错误

    由于 LAG 数据已过期,重新启动 vpxd 后,vSphere Web Client 可能会在 VDS 拓扑中显示错误。在重新启动之前,可能不会使用添加到 LAG 的物理适配器的数据更新 vCenter Server 数据库,且守护进程可能无法找到它。

    本版本已解决该问题。遇到此问题时,必须将物理适配器重新分配给 LAG。

  • vSphere ESX Agent Manager (EAM) 无法将代理映射到 NSX 主机群集中的新 ESXi 主机

    由于 vpxd 中出现同步问题,EAM 可能无法将代理映射到 NSX 受管群集中新添加的 ESXi 主机。
    EAM 日志可能包含类似以下内容的条目:
    ​| ERROR | vc-callback | AgencyImpl.java | 1295 | Failed to add agent to agency (AgencyImpl(ID:'Agency:XXXXX')): java.lang.RuntimeException: Host is no longer in vCenter inventory | WARN | eam-0 | AgencyImpl.java | 1954 | Disposing agency: AgencyImpl(ID:'Agency:XXXXXXX') due to failed load up.|

    ERROR | eam-0 | AgencyImpl.java | 1895 | Failed to load agent: ManagedObjectReference: type = Agent, value = f18cd000-dcd5-4d30-8d6b-5f12b04e46fa, serverGuid = b0827a9b-fccd-41dd-8b27-caf8418da719.Error: null java.lang.NullPointerException | ERROR | eam-0 | VcListener.java | 116 | An unexpected error in the changes polling loop

    本版本已解决该问题。

  • 如果已从 NSX 主机群集中移除 ESXi 主机,则 EAM 可能无法启动

    如果在 EAM 服务由于某种原因未正常工作的情况下将 ESXi 主机移出 NSX 主机群集,则 EAM 可能会无法启动。通过此修复,EAM 将不会在已移出其先前代理机构的主机上加载代理,并允许 EAM 启动。在 EAM 启动后,可以将已移置的主机移动到其代理机构和群集中。EAM 日志可能包含类似以下内容的条目:

    | ERROR | eam-0 | VcListener.java | 116 | An unexpected error in the changes polling loop

    | ERROR | eam-0 | AgencyImpl.java | 1895 | Failed to load agent: ManagedObjectReference: type = Agent, value = d6429441-6953-4795-81ff-efc455232e9a, serverGuid = b0827a9b-fccd-41dd-8b27-caf8418da719.Error: Host not covered by scope anymore

    本版本已解决该问题。

  • 使用 vSphere Web Client 将主机添加到 Cisco N1K DVS 可能会失败

    使用 vSphere Web Client 将主机添加到 Cisco N1K DVS 可能会失败,并显示类似以下内容的错误:每个主机的物理网络适配器数超过上行链路端口数 (The number of physical network adapter per host exceeds the number of uplink ports)

    本版本已解决该问题。

  • 故障切换后,VMware vSphere High Availability 可能无法打开辅助虚拟机的电源

    由于缺少端口文件,故障切换后,vSphere High Availability 可能无法打开辅助虚拟机的电源。升级到 vCenter Server 6.0 Update 3g 后,必须先关闭 vSphere Fault Tolerance 然后再重新启动,才能在主虚拟机和辅助虚拟机的数据存储中创建端口文件。

    本版本已解决该问题。

安全问题
  • Pivotal tc Server 许可证已在 2018 年 3 月过期

    Pivotal tc Server 许可证已在 2018 年 3 月过期。服务器通过单个物理安装提供 Apache Tomcat 8.5.24 访问并运行多个 Tomcat 运行时实例。当前更新会移除 tc Server 依赖关系,vCenter Server 上的所有服务将直接使用 Apache Tomcat。

    本版本已解决该问题。

  • Apache Struts 框架更新

    Apache Struts 框架已更新到版本 2.5.16,以解决标识符为 CVE-2018-1327 的安全问题。

  • vPostgres 更新

    vPostgres 已更新到版本 9.3.22,以解决标识符为 CVE-2018-1058 的安全问题。

  • JRE 更新

    Oracle (Sun) JRE 已更新到版本 1.7.0_181。

  • vCenter Server Appliance 中的 cURL 已更新到 7.58

    vCenter Server Appliance 中的 cURL 已更新到 7.58,解决了标识符为 CVE-2017-8818、CVE-2017-8817、CVE-2018-1000007 和 CVE-2018-1000005 的问题。

  • Python 更新

    Python 第三方库已更新到版本 2.7.14,以解决标识符为 CVE-2017-1000158 和 CVE-2014-4616 的安全问题。

  • VMware Certificate Authority (CA) 证书的默认有效期已减至 2 年

    所有 VMware CA 证书的默认有效期已从 10 年减至 2 年。根据 CA/浏览器论坛建议,VMware CA 证书最多在 825 天后到期。

  • Jackson 库更新

    Jackson JavaScript Object Notation (JSON) 处理器软件包已更新到版本 2.9.5。

服务器配置问题
  • vCenter Server Appliance 嵌入式数据库内存中的打开游标可能会导致性能和磁盘空间问题

    在 vCenter Server Appliance 中的嵌入式 PostgreSQL 数据库中关闭 SQL 句柄或者释放关联游标和内存资源失败可能会导致表和索引无限扩展。这可能会导致磁盘空间和性能下降。

    本版本已解决该问题。 

  • 如果移除 ESXi 主机上的可插入存储架构 (PSA) 路径,vCenter Server 可能会停止响应

    如果在 vCenter Server 未运行时移除 ESXi 上的 PSA 路径,则 vCenter Server 重新启动时会将其作为新路径添加。这可能导致 vCenter Server 停止响应,并显示以下错误消息:错误: 重复键值违反唯一性约束“vpxi_psa_path” (ERROR: duplicate key value violates unique constraint "vpxi_psa_path")。

    本版本已解决该问题。

  • 大型数据存储群集中的 vSphere Storage DRS 任务可能需要很长时间才能完成

    由于数据存储标记查询速度缓慢,大型数据存储群集中的 vSphere Storage DRS 任务可能需要很长时间才能完成。为了缓解此问题,vCenter Server 6.0 Update 3g 引入了 SrmSupportNeeded 标记这一数据存储群集高级选项设置。标记值设置为 1,默认情况下处于启用状态。通过将参数值设置为 0,可以在不需要 Site Recovery Manager 支持时关闭此标记。因此,这会提高 vSphere Storage DRS 任务性能。此外,默认情况下 BatchTagQuery 高级选项处于启用状态,这也会提高任务性能。

    本版本已解决该问题。

存储问题
  • 存储警报和事件消息显示为未知事件 ID 或未知消息标识符

    发布到 vCenter Server 时,存储警报和事件消息未正确转换。因此,它们会显示为未知事件 ID未知消息标识符

    本版本已解决该问题。

工具问题
  • SNMP v3 代理允许具有 priv 安全级别的用户仅提供身份验证密钥短语或无需提供安全密钥短语即可访问数据

    SNMP v3 代理允许具有 priv 安全级别的用户仅提供身份验证密钥短语或无需提供安全密钥短语即可访问数据。具有 priv 安全级别的用户必须同时提供身份验证密钥短语和私有密钥短语。 

    本版本已解决该问题。

  • vSphere Web Client 可能显示不一致的 VMware Tools 安装状态

    如果在客户机虚拟机上多次手动重新安装相同版本的 VMware Tools,则 ESXi 主机可能会收到相矛盾的报告,指出 VMware Tools 未安装,同时 VMware Tools 操作正在运行。此时,vSphere Web Client 显示类似以下内容的警告消息:VMware Tools: 正在运行,版本: 10304 (未安装) (VMware Tools: Running, version: 10304 (Not installed))。

    本版本已解决该问题。 

  • 将计算机 SSL 证书替换为自定义证书颁发机构 (CA) 签名的证书可能会失败并显示错误

    由于主机条目验证错误,使用 vSphere 证书管理器实用程序中的“替换计算机 SSL 证书”选项可能会失败并显示消息:在 0 深度查找时发生错误 20: 无法获取本地颁发者证书 (error 20 at 0 depth lookup:unable to get local issuer certificate)

    本版本已解决该问题。如果使用的是较旧版本的 vCenter Server 6.0,则可以在 vCenter Server Appliance 的 /usr/lib/vmware/site-packages/cis/certificateManagerHelper.py 上将参数值 return isresult 更改为 return True对于 Windows 上的 vCenter Server,路径为 C:\Program Files\VMware\vCenter Server\python-modules\cis\certificateManagerHelper.py

vCenter Server、vSphere Web Client 和 vSphere Client 问题
  • 由于 dnsmasq 日志堆积,vCenter Server Appliance 可能会用尽磁盘空间

    dnsmasq 日志可能不会轮换,而是堆积超过 vCenter Server Appliance 磁盘空间。

    本版本已解决该问题。

  • 如果分配的角色之一为“无权访问”,则组权限可能会导致用户的权限有限或被撤销

    如果用户属于两个或更多组,且其中一个组分配有“无权访问”角色,则用户可能只有有限权限或者没有有效权限。

    本版本已解决该问题。

  • 从清单视图关闭根文件夹时,vpxd 服务可能会失败

    如果将 ESXi 主机添加到群集并在此群集中创建 VMware vSphere vApp,当从 vSphere Web Client 中的清单视图导航到 vApp,则关闭根文件夹时,vpxd 可能会失败并显示错误:Panic: Assert Failed: "openedInfo._activations == 0"

    本版本已解决该问题。 

虚拟机管理问题
  • VMware vSphere Storage DRS 任务可能进入循环

    vSphere Storage DRS 任务可能进入无限循环,这会阻止同一存储群集的其他 vSphere Storage DRS 任务。您可能会看到 CPU 使用率很高或者 vSphere Storage DRS 任务超时。

    本版本已解决该问题。 

  • 将从 ESXi 5.5 主机导出的 OVF 模板部署到 ESXi 6.0 主机上的内容库可能会失败

    将从 ESXi 5.5 主机导出的 OVF 模板部署到 ESXi 6.0 主机上的内容库可能会失败,并显示错误:由于设备 8 的配置无效,操作失败 (The operation failed due to Invalid configuration for device 8)

    本版本已解决该问题。

  • 在资源可用性检查期间,EAM 可能会删除活动代理

    在资源可用性检查期间,EAM 可能会删除活动代理虚拟机,并导致数据丢失。此修复可防止 EAM 在因 CPU 和内存分配等资源限制而无法启动服务虚拟机的情况下删除活动代理以释放资源。

    本版本已解决该问题。

  • vSphere Storage DRS 的性能可能会因并行任务过多而降低

    您可以触发多个并行任务以处理 vSphere Storage DRS 中的阈值违反事件,因为不会针对此类任务执行检查。这可能会降低 vSphere Storage DRS 的性能。

    本版本已解决该问题。 

  • 在虚拟机部署期间,vCenter Server 可能会停止响应

    部署新虚拟机时,如果在使用 vSphere Storage DRS 初始放置虚拟磁盘期间数据存储变得不可用,则 vCenter Server 可能会停止响应。

    本版本已解决该问题。

  • 在禁用 IPv6 支持时尝试虚拟机置备操作会导致 ESXi 主机断开连接

    网络文件复制守护进程 (NFCD) 在 ESXi 主机上同时创建 IPv4 和 IPv6 套接字。如果在禁用 IPv6 支持时通过使用置备 TCP/IP 堆栈尝试虚拟机置备操作(如冷迁移或克隆),则主机可能会断开网络连接,而不使用 IPv4 套接字。

    本版本已解决该问题。

  • 尝试将新磁盘添加到虚拟机时,vCenter Server 可能会停止响应

    尝试将虚拟磁盘添加到虚拟机时,vSphere Storage DRS 在生成数据存储库建议时可能导致 vCenter Server 停止响应。

    本版本已解决该问题。

  • VMware Site Recovery Manager 工作流可能会因争用情况而失败

    Site Recovery Manager 工作流(如测试恢复计划)可能会因争用情况而失败,并显示类似以下内容的错误:java.util.concurrent.ExecutionException: com.vmware.vim.vmomi.client.exception.InternalException: Trying to override already set SSL user token with different one。在 vCenter Sever Appliance 中,可以在 var/log/vmware/workflow/workflow-manager.log 中找到该错误。

    本版本已解决该问题。

  • 如果虚拟机更改群集,则可能会禁用 DRS 关联性规则

    如果虚拟机具有虚拟机-虚拟机关联性或反关联性规则,将该虚拟机从一个群集移动到另一个群集,稍后再返回到第一个群集,则关联性规则可能不再处于活动状态。在 vpxd 日志中,您可能会看到一些报告,这些报告显示导致现有规则被禁用的规则冲突。

    本版本已解决该问题。 

  • 调度虚拟机硬件版本升级时,虚拟机操作失败并显示兼容性错误

    调度虚拟机硬件版本升级时,虚拟机操作失败并显示以下兼容性错误消息:目标主机与调度升级的虚拟机的硬件版本不兼容 (The destination host is not compatible with the hardware version to which the virtual machine is scheduled to be upgraded)。有关详细信息,请参见 VMware 知识库文章 2080107

    本版本已解决该问题。

vMotion 和 Storage vMotion 问题
  • 通过使用 vSphere Storage vMotion 或 XvMotion 迁移虚拟机期间,vCenter Server 可能变得无响应

    尝试对具有两个或更多快照(每个快照包含相同的独立磁盘)的虚拟机执行 Storage vMotion 或 XvMotion 迁移时,vCenter Server 可能变得无响应。

    本版本已解决该问题。

  • 在 vCenter Server 系统中迁移虚拟机可能失败,并显示“无权限 (No Permission)”错误

    在 vCenter Server 系统中迁移虚拟机时,即使具有目标对象的 System.Read 特权,如果没有目标数据中心的 System.Read 特权,则迁移可能会失败并显示“无权限 (No Permission)”错误。

    本版本已解决该问题。

vSAN 问题
  • vSAN 需要 RVC 才能配置 vSAN Observer 的 TLS 协议版本

    仅当从 RVC 命令行界面运行 vSAN Observer 时,才能读取 TLS 协议版本。TLS 版本未存储在配置文件中。如果从 vCenter Server 运行 vSAN Observer,则无法读取 TLS 版本。

    本版本已解决该问题。

  • 当延伸群集的一个站点关闭时,vSAN 运行状况服务可能无法加载

    当延伸群集的一个站点中的所有主机关闭时,由于出现意外的异常,vSAN 运行状况服务可能无法加载并显示任何数据。

    本版本已解决该问题。

已知问题

已知问题分为如下类别。

安装、升级和迁移问题
  • 在数据导出期间,从 Windows 上的 vCenter Server 5.5.x 和 6.0.x 迁移到 vCenter Server Appliance 6.5.x 可能会失败

    在数据导出期间从 Windows 5.5.x 和 6.0.x 上的 vCenter Server 迁移到 vCenter Server Appliance 6.5.x 可能会失败并出现诸如压缩的 zip 文件夹无效或损坏的错误。

    解决办法:手动存档数据导出文件夹:

    1. 在源 Windows 系统中,创建环境变量 MA_INTERACTIVE_MODE
      • 转到计算机 > 属性 > 高级系统设置 > 环境变量 > 系统变量 > 新建
      • 输入变量名称 MA_INTERACTIVE_MODE,值为 0 或 1。
    2. 启动 VMware Migration Assistant,并提供您的密码。
    3. 使用独立安装程序部署 .ovf 文件以完成迁移的第 1 阶段。
    4. 在第 2 阶段,迁移将暂停,并且 Migration Assistant 控制台会显示以下消息:要继续迁移,请从导出数据 (包括导出文件夹) 手动创建 export.zip 文件 (To continue the migration, create the export.zip file manually from the export data (include export folder))
      注意:请勿按 Migration Assistant 控制台上的任何键或选项卡。
    5. 转到路径:%appdata%\vmware\migration-assistant 文件夹。
    6. 删除 Migration Assistant 创建的 export.zip 文件夹。
    7. 要继续迁移,请从导出文件夹中手动创建 export.zip 文件夹。
    8. 在 Migration Assistant 控制台中,键入 Y 并按 Enter。

    迁移应该会照常启动。

  • 升级适用于 Windows 的 vCenter Server 可能会失败并显示错误代码 3010

    如果 OpenSSL 软件包版本高于更新版本,将适用于 Windows 的 vCenter Server 升级到版本 6.x 可能会失败并显示错误:组件 VMware vCenter Server 安装失败,错误代码 3010。请查看日志以了解更多详细信息 (Installation of component VMware vCenter Server failed with error code '3010'. Check the logs for more details)

    %TEMP%\vminst.log 文件中,可能会看到类似以下内容的日志:

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| E: wWinMain: MSI result of install of "E:\vCenter-Server\Packages\vmware-vpxd.msi" may have failed: 3010 (0x00000bc2)

    YYYY-MM-DD>T<time>| vcsInstUtil-4541944| E: LaunchPkgMgr: Operation on vmware-vpxd.msi appears to have failed: 3010 (0x00000bc2)

    YYYY-MM-DD>T<time>| vcsInstUtil-4541944| I: PitCA_MessageBox: Displaying message: "Installation of component VMware vCenter Server failed with error code '3010'.Check the logs for more details.

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| E: wWinMain: MSI result of install of "E:\vCenter-Server\Packages\vmware-openssl.msi" may have failed: 3010 (0x00000bc2)

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| E: LaunchPkgMgr: Operation on vmware-openssl.msi appears to have failed: 3010 (0x00000bc2)

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| I: PitCA_MessageBox: Displaying message: "Installation of component VMware Open SSL components failed with error code '3010'.Check the logs for more details."

     

    pkgmgr-comp-msi.log 文件中,可能会看到类似以下内容的日志:

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| I: UpdatePackageList: File: Z:\vCenter-Server\Packages\vmware-openssl.msi

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| I: UpdatePackageList: VersionCompare - Version: 6.0.0.9090 VersionInstalled: 6.0.0.60000 Res: -1

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| I: UpdatePackageList: ProductCodeCompare - ProductCode: {3D2B421E-617E-46F2-A83F-BF8AB22DBAAF} ProductCodeInstalled: {7CA4FE96-7C9E-40ED-ABF7-3EA5D78529D3} Res: -1

    YYYY-MM-DD>T<time>| vcsInstUtil-5318198| I: UpdatePackageList: Disabling installation of package Z:\vCenter-Server\Packages\vmware-openssl.msi (ProductCode is different but ProductVersion is smaller than the one already on the system)

    解决办法: 

    1. 打开 Windows 注册表 regedit.exe
    2. HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ 中搜索键 7CA4FE96-7C9E-40ED-ABF7-3EA5D78529D3。如果找到该键,则进行备份并将其移除。
    3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\ 中搜索值 6.0.0.60000如果找到该值,则进行备份并将其移除。
    4. 重试升级。
  • 从 vCenter Server 6.0、6.0.0a 和 6.0.0b 修补到 vCenter Server 6.0 Update 3g 可能需要太长时间

    将 vCenter Server Appliance 从 vCenter Server 6.0、vCenter Server 6.0.0a 或 vCenter Server 6.0.0b 修补到 vCenter Server 6.0 Update 3g 时,由于 RPM 更新问题,该过程可能需要太长时间。所有服务都可能变得暂时不可用。

    解决办法:无。有关此问题的详细信息,请参见知识库文章 56625

  • 在修补后,VMware vCenter Single Sign-On Security Token Service (STS) 可能不会保留任何自定义 TLS 配置

    在修补后,STS 服务可能不会保留任何自定义 TLS 配置。相反,会启用 TLSv1、TLSv1.1 和 TLSv1.2 协议。

    解决办法:使用 TLS Configurator 实用程序还原 TLSv1.2 配置。

其他问题
  • 如果您使用 Firefox 登录 vSphere Web Client,客户端集成插件可能无法按预期运行

    如果在 Windows 或 Mac OS 中使用 Firefox 登录 vSphere Web Client,则执行与客户端集成插件相关的任务时,可能会遇到以下问题:

    •  无法导出或导入 OVF 文件 (.ovf)。
    •  无法将文件上载或下载到数据存储。
    •  无法进行 Windows 会话身份验证 (SSPI) 登录。
    •  无法上载或下载到内容库。

    您可能还会看到以下信息:未安装客户端集成插件 (Client integration plug-in is not installed)。请安装并刷新浏览器。

    解决办法:可以使用替代浏览器,如 Google Chrome 或 Internet Explorer。

  • 客户端集成插件安装可能会失败

    客户端集成插件安装可能会失败。Windows 主机上未安装 Microsoft Visual C++ Redistributable Packages for Visual Studio。

    解决办法:在安装客户端集成插件之前,下载并安装受系统支持的缺失的 Microsoft Visual C++ Redistributable Packages for Visual Studio。可以使用添加/删除程序检查主机上是否安装了软件包。可以在 Microsoft 网站上不同版本的 Visual C++ Redistributable Packages 的“系统要求”部分中,基于 Windows 的版本检查所需的软件包。同时安装 x86.exe 和 x64.exe 的 Microsoft Visual C++ Redistributable Packages for Visual Studio。

  • 较旧版本的 vSphere Web Client 可能无法检测到最新版本的客户端集成插件

    由于 VMware vCenter Server 6.0 Update 3g 产品内部版本发生更改,较旧版本的 vSphere Web Client 可能无法检测到最新版本的客户端集成插件。这些更改与客户端集成插件和 vSphere Web Client 均相关。

    解决办法:通过使用 vSphere Web Client 访问 VMware vCenter Server 6.0 Update 3g 时,升级到最新的客户端集成插件版本。

早期版本的已知问题

查看以前的已知问题列表,请单击此处

check-circle-line exclamation-circle-line close-line
Scroll to top icon