当数据库设置为不支持的版本的兼容性模式时,使用 Microsoft SQL 数据库的 vCenter Server 安装会失败。

将显示以下错误消息:输入的数据库用户没有使用选定数据库安装和配置 vCenter Server 所需的必要权限。(The DB User entered does not have the required permissions needed to install and configure vCenter Server with the selected DB.)请更正以下错误: (Please correct the following error(s):)%s

数据库版本必须是 vCenter Server 支持的版本。对于 SQL,即使数据库是受支持的版本,但如果将其设置为以不支持的版本的兼容性模式运行,仍会发生此错误。例如,如果将 SQL 2008 设置为以 SQL 2000 兼容性模式运行,就会发生此错误。

过程

请确保 vCenter Server 数据库是受支持的版本,并且没有设置为以不支持的版本的兼容性模式运行。请参见 http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php? 上的 VMware 产品互操作性列表。