主机上的 vSphere HA 代理处于“网络已隔离”状况。需要用户干预来解决这种情况。

问题

当主机处于“网络已隔离”状态时,需要考虑两个方面:已隔离的主机和具有主角色的 vSphere HA 代理。

  • 在已隔离的主机上,vSphere HA 代理将对正在运行的虚拟机应用已配置的隔离响应,确定它们是否应该关机或关闭电源。检查主代理是否能够负责每个虚拟机(通过锁定虚拟机的主数据存储)之后,vSphere HA 代理将执行此操作。如果不能,则代理将推迟对虚拟机应用隔离响应,并在短暂延迟之后重新检查数据存储的状态。
  • 如果 vSphere HA 主代理可以访问一个或多个数据存储,将监控在主机变为已隔离状态时在主机上运行的虚拟机并尝试重新启动已关闭电源或关机的任何虚拟机。

原因

如果满足以下两个条件,则主机处于网络隔离状态:

  • 隔离地址已配置且主机无法 ping 这些地址。
  • 主机上的 vSphere HA 代理无法访问其他集群主机上运行的任何代理。
注: 您的 vSphere HA 集群启用 vSAN 后,如果主机无法与集群中的其他 vSphere HA 代理通信且无法访问配置的隔离地址,则该主机将被确定为隔离状态。尽管 vSphere HA 代理使用 vSAN 网络进行代理间通信,但默认的隔离地址仍为主机的网关。因此,在默认的配置中,对于声明处于隔离状态的主机,网络均会失败。

解决方案

解决阻止主机 Ping 其隔离地址并与其他主机通信的网络问题。