尽管 vSphere HA 集群中的虚拟机打开电源已有几分钟,但仍被报告为不受 vSphere HA 保护。

问题

虚拟机打开电源几分钟后,其 vSphere HA 保护状况仍为不受保护,如果出现故障,vSphere HA 可能不会尝试重新启动该虚拟机。

原因

负责虚拟机的 vSphere HA 首选主机将虚拟机在出现故障后必须重新启动的信息保存到磁盘后,vCenter Server 会将该虚拟机报告为受保护。此过程可能会由于多种原因而失败。
  • 尚未选择 vSphere HA 首选主机,或者 vCenter Server 无法与其通信。

    在这种情况下,vCenter Server 将集群主机的 vSphere HA 主机状况报告为“代理无法访问”或“代理未初始化”,并报告尚未发现首选主机的集群配置问题。

  • 存在多台首选主机,且正在与 vCenter Server 通信的首选主机不负责该虚拟机。

    下列情况会出现问题:vCenter Server 正在与某台首选主机联系,但由于管理网络分区,存在多台首选主机,且正在与 vCenter Server 通信的代理不负责该虚拟机。如果 vCenter Server 将某些主机的 vSphere HA 状况报告为网络已分区,则可能会出现这种情况。

  • 代理无法访问存储虚拟机配置文件的数据存储。

    vCenter Server 可能与拥有虚拟机的 vSphere HA 首选主机保持联系,但代理无法访问存储虚拟机配置文件的数据存储。如果某种全部路径异常情况影响了集群中的所有主机,则会发生这种情况。

解决方案

  1. 确定 vCenter Server 是否与 vSphere HA 主要主机联系,如果没有,请解决此问题。
  2. 如果 vCenter Server 与首选主机联系,请确定是否存在网络分区,如果存在,请解决该问题。
  3. 如果问题持续存在,请确定其配置文件位于同一数据存储的其他虚拟机是否也不受保护。
  4. 如果这些虚拟机不受保护,请验证 vSphere HA 主机是否可以访问数据存储。
  5. 如果上述步骤都不能解决问题,请在运行虚拟机的主机上通过重新配置 vSphere HA 来还原保护。