虚拟机兼容性决定了虚拟机可用的虚拟硬件,该虚拟硬件与主机上可用的物理硬件相对应。您可调度兼容性升级,使虚拟机与更新版本的 ESXi 兼容。

关于此任务

使用该过程调度下次重新引导虚拟机时一个或多个虚拟机的升级,并从支持的所有兼容性级别升级中进行选择。要立即将虚拟机升级到支持的最新兼容性,请参见升级虚拟机的兼容性

有关虚拟机硬件版本和兼容性的信息,请参见虚拟机兼容性

先决条件

  • 创建虚拟机的备份或快照。请参见使用快照管理虚拟机

  • 升级到最新版本的 VMware Tools。如果在升级 VMware Tools 之前升级兼容性,则虚拟机可能会丢失其网络设置。

  • 确认所有 .vmdk 文件是否对 VMFS3、VMFS5 或 NFS 数据存储上的 ESX/ESXi 主机可用。

  • 确认虚拟机是否存储于 VMFS3、VMFS5 或 NFS 数据存储上。

  • 验证虚拟机的兼容性设置是否并非为支持的最新版本。

  • 确定虚拟机要与其兼容的 ESXi 版本。请参见虚拟机兼容性

过程

  1. vSphere Web Client 登录 vCenter Server。
  2. 选择虚拟机。
    1. 选择数据中心、文件夹、群集、资源池或主机。
    2. 单击虚拟机选项卡,然后单击虚拟机
  3. 关闭所选虚拟机电源。
  4. 选择操作 > 兼容性 > 调度虚拟机兼容性升级...
  5. 单击确认升级。
  6. 选择虚拟机要与其兼容的 ESXi 版本。
  7. (可选) : 选择仅在正常关闭客户机操作系统后升级

    这样可防止在虚拟机客户机操作系统正常关闭或重新启动以外的情况下发生调度的升级。

结果

所选每个虚拟机都会在下次重新引导虚拟机时升级到所选的兼容性,并且兼容性设置会在虚拟机的“摘要”选项卡中得到更新。