主机上的 vSphere HA 代理处于“网络已分区”状况。可能需要用户干预来解决这种情况。

问题

尽管主机上运行的虚拟机继续由负责它们的首选主机监控,但 vSphere HA 在出现故障后重新启动虚拟机的能力将受到影响。首先,每台首选主机都可以访问一部分主机,因此每台主机可用的故障切换容量降低。其次,在发生故障后,vSphere HA 可能无法重新启动 FT 辅助虚拟机。另请参见《vSphere 可用性》故障排除。

原因

如果满足以下两个条件,则会将主机报告为已分区:

  • vCenter Server 连接到的 vSphere HA 首选主机无法使用管理(或 VMware vSAN™)网络与主机通信,但可以使用已为其选择的检测信号数据存储与该主机通信。
  • 主机未隔离。

网络分区的出现有很多原因,包括 VLAN 标记错误、物理网卡或交换机发生故障、配置部分主机仅使用 IPv4 而其他主机仅使用 IPv6 的集群,或者部分主机的管理网络在没有先使主机进入维护模式的情况下移至其他虚拟交换机。

解决方案

解决阻止主机使用管理网络进行通信的网络连接问题。