主机上的 vSphere HA 代理处于未初始化状况一分钟或更长时间。可能需要用户干预来解决这种情况。

问题

当主机的代理无法进入运行状况并成为首选主机时,或无法连接到首选主机时,vSphere HA 会报告代理处于未初始化状况。因此,vSphere HA 无法监控该主机上的虚拟机,并且在出现故障后可能不会重新启动这些虚拟机。

原因

vSphere HA 代理可能因一个或多个原因而处于未初始化状况。这种情况通常表示主机对任何数据存储都没有访问权限。在少数情况下,表示主机对 vSphere HA 用来缓存状况信息的本地数据存储没有访问权限、主机上的代理无法访问或 vSphere HA 代理无法打开所需防火墙端口。也可能是 ESXi 主机代理已停止。

解决方案

在主机的事件列表中搜索近期发生的主机的 vSphere HA 代理出错 (vSphere HA Agent for the host has an error) 事件。此事件指明主机处于未初始化状况的原因。如果由于数据存储问题而出现这种情况,请解决任何阻止主机访问受影响数据存储的问题。如果 ESXi 主机代理已停止,必须重新启动。解决上述问题后,如果代理未返回到操作状况,请重新配置主机上的 vSphere HA。

注: 如果由于防火墙问题而出现这种情况,请检查主机上是否有其他服务在使用端口 8182。如果是这样,请关闭此服务,然后重新配置 vSphere HA。