必须升级所有外部 PostgreSQL 虚拟设备。如果您的部署使用负载平衡器,则必须单独升级每个 PostgreSQL 设备。该升级仅适用于采用 vPostgreSQL 服务器的 vRealize Automation Appliance

开始之前

  • 确认已下载虚拟设备更新。请参见下载 vRealize Automation 设备更新

  • 验证外部 PostgreSQL 设备是否满足与 vRealize Automation Appliance 相同的硬件要求。请参见硬件配置要求

  • 验证是否为负载平衡器流量禁用第二个和后续 PostgreSQL 设备。执行升级之前必须禁用它们。

关于此任务

如果您使用其他类型的 PostgreSQL 服务器(例如,社区版或共享的 PostgreSQL 服务器),请勿使用此过程。

过程

  1. 找到 vRealize Automation Appliance 并打开其电源。
  2. 打开 vRealize Automation Appliance 管理控制台进行升级。
    1. 通过使用完全限定域名 (https://va-hostname.domain.name:5480) 转到虚拟设备的管理控制台。
    2. 使用您在部署设备时指定的 root 用户名和密码登录。
    3. 单击更新选项卡。
  3. 单击设置并为更新选择下载选项。
  4. 单击状态
  5. 单击检查更新,确认更新可访问。
  6. 单击安装更新
  7. 单击确定
  8. 打开日志文件,确认升级进行顺利。

    /opt/vmware/var/log/vami/vami.log

    完成更新所需的时间取决于站点环境。

  9. 清除用于访问管理控制台的 Web 浏览器的缓存。
  10. 重新引导虚拟设备。
    1. 单击系统选项卡。
    2. 单击重新引导并确认您的选择。
  11. 将所有 PostgreSQL 虚拟设备重新连接到负载平衡器。

下一步做什么

在所有 vRealize Automation 设备节点上重新配置磁盘 1