运行升级之前,请检查必备条件。

系统配置要求

开始升级之前,确保满足以下系统要求。

  • 确认您遵循的是一个支持的升级路径。请参见 vRealize Automation 发行说明中支持的升级路径列表。

  • 确认部署中所有设备和服务器均符合升级后版本的系统要求。请参见 VMware 网站上的 vRealize Automation 支持列表,网址为 https://www.vmware.com/support/pubs/vcac-pubs.html

  • 有关与其他 VMware 产品兼容性的信息,请查阅 VMware 网站上的 VMware 产品互操作性列表

  • 确认要从中进行升级的 vRealize Automation 处于稳定工作状态下。如有问题,请在升级前进行更正。

  • 记录 vCloud Suite 许可证密钥(如果您在安装要从中进行升级的 vRealize Automation 时使用了该密钥)。升级之后,现有许可证密钥已从数据库中移除。

硬件配置要求

开始升级之前,确保满足以下硬件要求。

  • 下载升级之前,必须创建至少具有 50 GB 空间和 18 GB RAM 空间的磁盘。请参见增加 vCenter Server 硬件资源以便进行升级

    如果虚拟机位于 vCloud Networking and Security 上,您可能需要分配更多 RAM 空间。

    如果 vRealize Automation Appliance 中具有两个磁盘,则必须另外添加两个空间分别为 25 GB 和 50 GB 的磁盘 3 和磁盘 4。虚拟设备必须具有磁盘 3 和磁盘 4,升级过程才能成功。

  • 为避免以后的 vRealize Automation 升级因可用空间不足而失败,必须在所有 vRealize Automation 设备上将磁盘 1 的大小重新调整为 50 GB。 请参见第 19 页上的“调整磁盘 1 的大小以进行升级”。

  • CPU 必须具有四个虚拟插槽和一个内核。请参见增加 vCenter Server 硬件资源以便进行升级

  • IaaS 服务器节点必须安装了 Microsoft .NET Framework 4.5.2 并且具有至少 5 GB 的可用磁盘空间。

  • 根分区的每个 vRealize Automation Appliance 上必须具有至少 7 GB 可用磁盘空间,才能下载和运行升级。

  • 检查 /storage/log 子文件夹,并移除所有旧的存档 zip 文件,以清理空间。

常规必备条件

开始升级之前,确认已完成以下必备条件。

  • 您有权访问采用 username@domain 格式的 Active Directory 帐户,并且有权绑定到该目录。

    注:

    vRealize Automation 6.2.x 版本进行升级时,不会迁移 OpenLDAP 中的身份提供程序。

  • 您有权访问采用 SAMaccountName 格式的帐户,并且具有足够特权来通过动态创建计算机对象将系统加入域或合并到预先创建的对象。

  • 您有权访问在 vRealize Automation 升级过程中受影响或参与该升级过程的所有数据库和所有负载平衡器。

  • 执行升级时,用户无法使用系统。

  • 已经禁用任何用于查询 vRealize Automation 的应用程序。

  • 您遵循了 关闭 IaaS Windows 服务器上的 vCloud Automation Center 服务 中的说明。

  • 确认在所有 vRealize Automation 和关联的 SQL Server 上启用了 Microsoft 分布式事务处理协调器 (MSDTC)。有关说明,请参见 VMware 知识库文章《升级或迁移到 VMware vCloud Automation Center (vCAC) 6.1.x 后的各种任务失败 (2089503)》 (http://kb.vmware.com/kb/2089503)。

  • 如果您的站点使用外部 vRealize Orchestrator 设备,而部署使用与 Identity Appliance 连接的外部 vRealize Orchestrator 设备,则在升级 vRealize Automation 前请先升级 vRealize Orchestrator

  • 如果已安装公共组件目录,必须在升级之前将其卸载。有关如何安装、升级和卸载公共组件目录的信息,请参见公共组件目录文档。