从版本 7.0 开始,某些创建、读取、更新和删除操作会受到限制。如果使用了先前版本工作流的操作,则这些操作将无法用于 7.0 和更高版本。您可以将工作流更新为支持的操作,或可以重新启动所需的操作。

关于此任务

若要重新启用这些操作,必须将要启用的操作从 operations.properties 文件移除。有关文件中的操作列表,请参见受限制的操作

过程

  1. vRealize Orchestrator 的下拉菜单中,选择设计
  2. 单击资源视图。
  3. 在资源层次结构中,展开 > VCAC > Util
  4. 创建备份并修改 operations.properties 文件。
    1. 右键单击 operations.properties,然后选择保存为文件
    2. 将副本另存为备份。
    3. 创建新副本并删除想要重新启用的操作。
    4. 保存新文件。
  5. 替换 vRealize Orchestrator 中的现有文件。
    1. vRealize Orchestrator 中,右键单击 Util 文件夹并单击导入资源
    2. 浏览到新版本的 operations.properties 文件,然后单击打开
    3. 单击替换一次以保存修改后的版本。
  6. 重新启动 vRealize Orchestrator 服务器。
  7. 选择 operations.properties 文件,然后单击查看器选项卡。
  8. 验证要启用的操作是否已不在文件中。

结果

从文件中移除的操作现在可用于较旧的工作流。

下一步做什么

创建新工作流时,避免使用受限制的操作。