向 vRealize Automation 注册 vRealize Business for Cloud 之后,vRealize Automation 用户界面中不显示业务管理选项卡。
问题
向 vRealize Automation 注册 vRealize Business for Cloud 并将业务管理或租户管理员角色添加到用户之后,vRealize Automation 用户界面中不显示业务管理选项卡。日志文件中没有报告错误。
原因
此问题可能是以下情况之一引起的。
- 当 vRealize Automation 的 IaaS 组件不可用时。
- 当 vRealize Automation 数据缓存在服务器上时。
解决方案
- 执行下列步骤之一。
选项 描述 vRealize Automation IaaS 组件问题 - 通过使用 root 凭据登录到 vRealize Automation 虚拟设备。
- 在 /etc/vcac 下创建 extension.properties 文件并隐藏主页选项卡。
shell.disabledExtensions=csp.home.可以通过使用
shell.disabledExtensions=<extension-id>[,<extension-id>]隐藏其他选项卡 - 重新启动 vRealize Automation 虚拟设备。
- 登录到 vRealize Automation 界面。此时应显示“业务管理”选项卡。
vRealize Automation 缓存问题 - 通过 administrator@vsphere.local 凭据登录到 vRealize Automation。
- 编辑用户租户,然后单击更新。
- 注销并使用租户 URL 以租户身份重新登录。