vRealize Business for Cloud报告存储不足,无法存储大型公有云帐单。
问题
如果解压缩后的 AWS 或 Azure 帐单文件大小较大,则虚拟设备存储不足,无法存储帐单。
原因
如果解压缩后的 AWS 或 Azure 帐单文件较大,则会发生此问题。硬盘空间不足会影响数据收集过程及其他需要存储访问的过程。
解决方案
- 关闭 vRealize Business for Cloud设备。
- 在 vRealize Business for Cloud中添加新硬盘。
- 打开虚拟设备电源。
- 使用安全套接字层连接到虚拟设备。
- 在 shell 客户端,要列出所有磁盘并标识新添加磁盘的设备 ID,请运行 fdisk-lu。
注:
默认情况下,新磁盘的设备 ID 为
/dev/sdb
。 - 访问新磁盘的磁盘实用程序并运行 fdisk /dev/sdb 命令。
- 针对新分区,请按 n,再按 Enter 键。
- 针对主分区,请按 p,再按 Enter 键。
- 针对分区编号,请按 1。
- 接受默认起始块和默认结束块(按 Enter 键两次对起始块和结束块使用默认值)。
- 按 w 向磁盘写入分区表。
- 在新磁盘上创建分区。
- 要在新磁盘上创建 ext3 文件系统,请运行 mkfs-t ext3/dev/sdb1。
- 如果 AWS 或 Azure 帐单大小较大,请运行 mount /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp/ 以将数据收集器挂载到新磁盘上的临时位置。
- 运行 mount -l。
该命令将确认是否已正确挂载新分区。请查看输出中是否包含
/dev/sdb1 on /usr/local/tomcat/itbm-data-collector/temp type ext3 (rw,relatime,data=ordered)
。 - 要使用 vi 打开文件,请运行 vi /etc/fstab。
- 添加 /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp ext3 defaults 1 1。
此步骤可确保虚拟设备重新启动时不会卸载磁盘。
解决方案
增加 vRealize Business for Cloud虚拟设备的大小。