有关 Log Insight Agents实例的信息未在“管理”UI 的“代理”页面上显示。

问题

安装 Log Insight Agents后,在“管理”UI 的“代理”页面中看不到 Log Insight Agents

原因

最常见的原因是出现网络连接问题或 liagent.ini 文件中的 Log Insight Agents 配置得不正确。

解决方案

  • 验证安装了 Log Insight Agents的 Windows 或 Linux 系统是否已连接到 vRealize Log Insight 服务器。
  • 验证 Log Insight Agents 是否使用 cfapi 协议。
    如果使用 syslog 协议,UI 不会显示 Log Insight Windows Agents
  • 查看位于以下目录中的 Log Insight Agents 日志文件的内容。
    • Windows - %ProgramData%\VMware\Log Insight Agent\log
    • Linux - /var/log/loginsight-agent/
    查找包含以下短语的日志消息: Config transport error: Couldn't resolve host nameResolver failed.No such host is known.
  • 验证 liagent.ini 是否包含目标 vRealize Log Insight 服务器的正确配置。请参见设置 Log Insight Windows 代理的目标 Log Insight 服务器设置 Log Insight Linux 代理的目标 Log Insight 服务器