vRealize Orchestrator 用例说明了如何使用第三方模块调用 vRealize Automation 项目 API。

vRealize Orchestrator 8.1 开始,您可以使用以下运行时:

  • Python 3.7
  • Node.js 12
  • PowerCLI 11/Powershell 6.2
  • PowerCLI 12/Powershell 7
    注: PowerCLI 运行时包括 PowerShell 和以下模块:VMware.PowerCLI、PowerNSX 和 PowervRA。

在此用例中,您将了解如何创建使用第三方依赖关系模块连接到 vRealize Automation 项目 API 的 vRealize Orchestrator 操作。

重要事项: 开始开发自定义脚本之前,确认您熟悉在 vRealize Orchestrator 中使用 Python、Node.js 和 PowerShell 脚本的核心概念。请参见 Python、Node.js 和 PowerShell 脚本的核心概念