Einige der Metriken hängen von Helpdesk-APIs ab.

Problem

Fehlende Helpdesk-Metriken aufgrund der Helpdesk-API

Alle Protokollmetriken, Leistungsverlaufs- und Anwendungsmetriken in Horizon-Sitzungen fehlen.

Ursache

  1. Wenn das Flag „Aktivieren der Erfassung historischer Leistungsmetriken für RDS“ ist auf „False“ festgelegt ist, werden die werden die Metriken für die Gesamt-CPU, den Gesamtspeicher und die Festplatten-IOPS deaktiviert und Helpdesk-API-Aufrufe für historische Leistungsmetriken abgeschaltet.

  2. Wenn das Flag „Aktivieren der Erfassung der Protokollleistungsmetrik“ auf „False“ festgelegt ist, werden die Metriken „Frame-Rate“, „Latenz“, „Paketverlust bei Empfang“, „Paketverlust bei Übertragung“, „Übertragungsbandbreitennutzung“ deaktiviert und Helpdesk-API-Aufrufe für Protokollmetriken abgeschaltet.

  3. Wenn das Flag „Erfassung von Anwendungsmetriken aktivieren“ auf „False“ festgelegt ist, werden CPU- und Festplattenauslastungsmetriken deaktiviert und Helpdesk-API-Aufrufe für Horizon-Anwendungssitzungen ausgeschaltet.

  4. Helpdesk-API-Plug-In ist im Horizon Agent nicht aktiviert. Der Adapter kann keine Metriken erfassen. Als Symptom wird die Fehlermeldung „ErrorCode=1001 - Unable to forward message to the AgentHelpDesk queue: NoQueueHandler“ in den Protokollen angezeigt.

Lösung

  1. Aktivieren Sie das Helpdesk-Plug-In im Horizon Agent und stellen Sie sicher, dass die Horizon Helpdesk-Lizenzen verfügbar sind.

  2. Aktivieren Sie die entsprechenden Flags in den erweiterten Adaptereinstellungen.