Bevor Sie ein Upgrade von Site Recovery Manager durchführen können, müssen Sie auf beiden Site Recovery Manager-Sites vorbereitende Aufgaben ausführen.

Voraussetzungen

  • Aufgrund von Zeitplänen für die Update-Freigabe werden Upgrades auf bestimmte 5.8.x-Update-Versionen von Site Recovery Manager nicht für alle Versionen von 5.1.x und 5.5.x unterstützt. Schlagen Sie den Upgrade-Pfad der Lösung > VMware vCenter Site Recovery Manager in den VMware-Produktinteroperabilitätstabellen unter http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php? nach, bevor Sie ein Upgrade durchführen, um sicherzustellen, dass Ihr Upgrade-Pfad unterstützt wird.

    Wichtig:

    Die Aktualisierung von Site Recovery Manager 5.0.x auf Site Recovery Manager 5.8 wird nicht unterstützt. Führen Sie ein Upgrade von Site Recovery Manager 5.0.x auf eine Site Recovery Manager 5.5.x-Version aus, bevor Sie das Upgrade auf Site Recovery Manager 5.8 vornehmen. Informationen zum Upgrade von 5.0.x auf 5.5.x finden Sie unter Durchführen eines Upgrades von Site Recovery Manager in der Dokumentation zu Site Recovery Manager 5.5.

  • Wenn Sie eine zertifikatsbasierte Authentifizierung verwenden, stellen Sie für den vSphere Web Client-Dienst das Zertifikat für die Remote-Site auf jeder Website bereit. Weitere Informationen hierzu finden Sie unter Bereitstellen vertrauenswürdiger CA-Zertifikate für vSphere Web Client.

  • Um Site Recovery Manager mit vSphere Replication zu verwenden, stellen Sie die geeignete Version von vSphere Replication auf der Schutz- und der Wiederherstellungs-Site bereit, bevor Sie ein Upgrade des Site Recovery Manager Server durchführen. Das Site Recovery Manager-Installationsprogramm überprüft die Version von vSphere Replication während der Installation und hält an, wenn eine nicht kompatible Version erkannt wird. Diese Überprüfung wird nicht durchgeführt, wenn Sie vSphere Replication installieren, nachdem Sie ein Upgrade des Site Recovery Manager Server durchgeführt haben, was zu nicht kompatiblen Versionen führen kann. Nicht kompatible Versionen von Site Recovery Manager und vSphere Replication bewirken, dass vSphere Web Client nicht mehr funktioniert. Informationen zur Kompatibilität zwischen vSphere Replication- und Site Recovery Manager-Versionen finden Sie in den Anforderungen für vSphere Replication im Kompatibilitätstabellen für vCenter Site Recovery Manager 5.8 unter https://www.vmware.com/support/srm/srm-compat-matrix-5-8.html.

  • Wenn auf den Sites vSphere Replication-Appliances vorhanden sind, müssen Sie für diese entweder ein Upgrade auf die korrekte Version durchführen oder sie aus der Registrierung beider vCenter Server-Instanzen entfernen, bevor Sie ein Upgrade von Site Recovery Manager durchführen. Nicht kompatible Versionen von Site Recovery Manager und vSphere Replication bewirken, dass vSphere Web Client nicht mehr funktioniert. Weitere Informationen hierzu finden Sie unter Aufheben der Registrierung einer inkompatiblen Version von vSphere Replication.

  • Die Migration der Daten aus einer externen Datenbank in die eingebettete Datenbank wird nicht unterstützt. Weitere Informationen über das Sichern der eingebetteten Datenbank finden Sie unter Sichern und Wiederherstellen der eingebetteten vPostgres-Datenbank.

  • Wichtig:

    Stellen Sie sicher, dass bei den virtuellen Maschinen, die von Site Recovery Manager geschützt werden, keine Bereinigungsvorgänge auf Wiederherstellungsplänen anstehen und keine Konfigurationsprobleme vorliegen.

    • Alle Wiederherstellungspläne weisen den Status „Bereit“ auf.

    • Der Schutzstatus aller Schutzgruppen lautet „OK“.

    • Der Schutzstatus aller virtuellen Maschinen in der Schutzgruppe lautet „OK“.

    • Der Wiederherstellungsstatus aller Schutzgruppen lautet „Bereit“.

  • Wenn Sie in der bestehenden Installation erweiterte Einstellungen konfiguriert haben, notieren Sie sich die Einstellungen, die Sie vor dem Upgrade konfiguriert haben.

  • Die lokalen und Remote-vCenter Server-Instanzen müssen ausgeführt werden, wenn Sie Site Recovery Manager aktualisieren.

  • Führen Sie ein Upgrade aller vCenter Server-Komponenten und von Site Recovery Manager auf einer Site durch, bevor Sie vCenter Server und Site Recovery Manager auf der anderen Site upgraden.

  • Laden Sie die Site Recovery Manager-Installationsdatei auf den Maschinen in einen Ordner herunter, auf denen ein Upgrade von Site Recovery Manager durchgeführt werden soll.

  • Stellen Sie sicher, dass kein Neustart auf der Windows-Maschine aussteht, auf der Site Recovery Manager Server installiert werden soll. Stellen Sie sicher, dass keine andere Installation ausgeführt wird, auch keine unbeaufsichtigte Installation von Windows-Updates. Ausstehende Neustarts oder laufende Installationen können dazu führen, dass die Installation von Site Recovery Manager Server fehlschlägt.

Prozedur

  1. Sichern Sie die Site Recovery Manager-Datenbank unter Verwendung der Tools der Datenbanksoftware.
  2. Upgrade von vCenter Server.

    Site Recovery Manager 5.8.0 benötigt vCenter Server 5.5 Update 2. Informationen zur Kompatibilität zwischen Update-Versionen von vCenter Server und Site Recovery Manager 5.8 finden Sie in den Anforderungen für vCenter Server im Kompatibilitätstabellen für vCenter Site Recovery Manager 5.8 unter https://www.vmware.com/support/srm/srm-compat-matrix-5-8.html.

    Wichtig:

    Sie müssen ein Upgrade für alle Komponenten von vCenter Server durchführen, was Inventory Service sowie den vCenter Server umfasst.

  3. Führen Sie ein Upgrade des vSphere Web Client-Servers durch.

    Site Recovery Manager 5.8 erfordert die entsprechende Version des vSphere Web Client. Site Recovery Manager 5.8 unterstützt nicht den vSphere Client für Windows.

  4. Upgrade von vSphere Replication.

    Site Recovery Manager 5.8.0 benötigt vSphere Replication 5.8.0. Falls Sie kein Upgrade von vSphere Replication durchführen können, müssen Sie die Registrierung der vSphere Replication-Appliance von vCenter Server aufheben.