Wenn viele virtuelle Maschinen gleichzeitig Startvorgänge durchführen, treten während der Array-basierten und der vSphere Replication-Wiederherstellung möglicherweise Fehler auf.

Problem

Wenn Sie auf der Wiederherstellungs-Site viele virtuelle Maschinen gleichzeitig starten, sehen Sie in den Berichten zum Wiederherstellungsverlauf möglicherweise die folgenden Fehler (sinngemäß):

  • Den Befehl 'echo "Starting IP customization on Windows ..." > > % VMware_GuestOp_OutputFile%.
  • Die Anpassung kann nicht abgeschlossen werden, möglicherweise wegen des Laufzeitfehlers eines Skripts oder wegen ungültiger Skriptparameter.
  • Beim Hochladen von Dateien auf die Gast-VM ist ein Fehler aufgetreten.
  • Zeitüberschreitung beim Warten auf VMware Tools nach 600 Sekunden.

Ursache

Standardmäßig legt Site Recovery Manager für die Anzahl an gleichzeitigen Einschaltvorgängen keinen Grenzwert fest. Wenn beim Einschalten der virtuellen Maschinen auf der Wiederherstellungs-Site Fehler auftreten, können Sie in der Datei vmware-dr.xml die Anzahl an gleichzeitigen Einschaltvorgängen für virtuelle Maschinen begrenzen.

Falls diese Fehler auftreten, begrenzen Sie die Anzahl der Einschaltvorgänge auf der Wiederherstellungs-Site gemäß der Kapazität Ihrer Umgebung für einen eigenständigen Host oder einen Cluster.

Lösung

  1. Melden Sie sich beim Site Recovery Manager Server-Host an.
  2. Öffnen Sie die Datei vmware-dr.xml in einem Texteditor.
    Die Datei vmware-dr.xml befindet sich im Verzeichnis /opt/vmware/srm/conf/.
  3. Ändern Sie die Werte für defaultMaxBootAndShutdownOpsPerCluster und defaultMaxBootAndShutdownOpsPerHost, um die Anzahl der Einschaltvorgänge auf der Wiederherstellungs-Site zu begrenzen.
    Im folgenden Beispiel wurde die Anzahl der Einschaltvorgänge pro Cluster auf 32 und pro eigenständigem Host auf 4 begrenzt.
    <config>
      <defaultMaxBootAndShutdownOpsPerCluster>32</defaultMaxBootAndShutdownOpsPerCluster>
      <defaultMaxBootAndShutdownOpsPerHost>4</defaultMaxBootAndShutdownOpsPerHost>
    </config>
  4. Starten Sie den Site Recovery Manager Server-Dienst neu.