Das Neukonfigurieren von Site Recovery Manager schlägt nach einem Upgrade von einer vCenter Server 6.5.x- oder 6.7.x-Instanz mit einem externen Platform Services Controller auf einen eingebetteten vCenter Server 7.x-Knoten fehl.

Problem

Wenn Sie versuchen, Site Recovery Manager nach einem Upgrade einer vCenter Server 6.5.x- oder 6.7.x-Instanz mit einem externen Platform Services Controller auf einen vCenter Server mit einem eingebetteten 7.x-Knoten neu zu konfigurieren, schlägt der Vorgang mit einer Fehlermeldung fehl.
ERROR
Operation Failed
A general system error occurred: 22ConfigurationException Failed to configure DR server with the Infrastructure Node services. Reason: Fault cause: lookup.fault.EntryExistsFault

Exit code: 61

Ursache

Wenn Sie ein Upgrade einer vCenter Server 6.5.x- oder 6.7.x-Instanz mit einem externen Platform Services Controller auf eine vCenter Server 7.x-Instanz mit einem eingebetteten Knoten durchführen, ändert sich die Namens-ID der vCenter Single Sign-On-Site.

Lösung

  1. Notieren Sie sich die serviceId aus der Meldung Error 61.
  2. Melden Sie sich auf der Schutz-Site mit den vCenter Server-Anmeldedaten bei https://<vCenter_Server_address>/lookupservice/mob/ an.
  3. Navigieren Sie zu RetrieveServiceContent > Methode aufrufen > ServiceRegistration > Methode löschen, um serviceId: <serviceId> zu löschen.
  4. Melden Sie sich auf der Schutz-Site bei der Site Recovery Manager Appliance-Verwaltung als Administrator an.
  5. Klicken Sie auf Übersicht, dann auf Neu konfigurieren und befolgen Sie die Anweisungen.
  6. Notieren Sie sich die serviceId aus der Meldung Error 61.
  7. Melden Sie sich auf der Wiederherstellungs-Site-Site mit den vCenter Server-Anmeldedaten bei https://<vCenter_Server_address>/lookupservice/mob/ an.
  8. Navigieren Sie zu RetrieveServiceContent > Methode aufrufen > ServiceRegistration > Methode löschen, um serviceId: <serviceId> zu löschen.
  9. Melden Sie sich bei der Verwaltungsschnittstelle der Site Recovery Manager-Appliance als Administrator an.
  10. Klicken Sie in der Site Recovery Manager Appliance-Verwaltungsschnittstelle auf Dienste.
  11. Wählen Sie den Dienst srm-server aus, klicken Sie auf „Beenden“ und dann auf OK.
  12. Stellen Sie eine SSH-Verbindung zum aktualisierten eingebetteten vCenter Server her, führen Sie den folgenden Befehl aus und notieren Sie sich den Namen der vCenter Single Sign-On-Site.
    /usr/lib/vmware-vmafd/bin/vmafd-cli get-site-name --server-name localhost
  13. Stellen Sie eine SSH-Verbindung zum Site Recovery Manager her, führen Sie den folgenden Kommentar aus und notieren Sie sich die db_id.
    echo "select * from pds_solutionuser;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
    Hinweis: password ist das Kennwort für die eingebettete vPostgres-Datenbank, die Sie während der Installation von Site Recovery Manager festgelegt haben.
  14. Führen Sie den folgenden Befehl aus.
    echo "update pds_solutionuser set siteid = 'default-first-site' where db_id =<db_id> ;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
  15. Melden Sie sich auf der Wiederherstellungs-Site bei der Site Recovery Manager Appliance-Verwaltung als Administrator an und konfigurieren Sie Site Recovery Manager neu.
  16. Melden Sie sich auf der Schutz-Seite bei Site Recovery Manager an.
  17. Wählen Sie auf der Registerkarte „Home“ von Site Recovery ein Site-Paar aus und klicken Sie auf Details anzeigen.
  18. Wählen Sie Site-Paar > Übersicht aus und klicken Sie auf Erneut verbinden.
    1. Wenn ein Fehler auftritt, starten Sie sowohl die Site Recovery Manager-Instanzen als auch die vCenter Server-Instanzen neu und wiederholen Sie den Vorgang zum erneuten Verbinden.
      Unable to connect to Site Recovery Manager Server at https://<SRM FQDN/IP>:443/drserver/vcdr/vmomi/sdk. 
      Reason: java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-431 [ACTIVE]