Horizon Administrator kann eine ThinApp-Anwendung nicht deinstallieren.

Problem

Der Installationsstatus einer ThinApp-Anwendung weist auf einen Fehler bei der Deinstallation hin.

Ursache

Folgendes sind häufige Ursachen für diesen Fehler:

  • Die ThinApp-Anwendung wurde verwendet, als Horizon Administrator versucht hat, sie zu deinstallieren.
  • Die Netzwerkverbindung zwischen Verbindungsserver-Host und Computer wurde getrennt.

In den Horizon Agent- und Verbindungsserver-Protokolldateien finden Sie weitere Informationen zur Ursache des Problems.

Horizon Agent-Protokolldateien befinden sich auf dem Computer im Verzeichnis Laufwerk:\Dokumente und Einstellungen\All Users\Anwendungsdaten\VMware\VDM\logs (auf Windows XP-Systemen) und im Verzeichnis Laufwerk:\Programme\VMware\VDM\logs (auf Windows 7-Systemen).

Verbindungsserver-Protokolldateien befinden sich auf dem Verbindungsserver-Host im Verzeichnis Laufwerk:\Dokumente und Einstellungen\All Users\Anwendungsdaten\VMware\VDM\logs.

Lösung

  1. Wählen Sie in Horizon Administrator Katalog > ThinApps aus.
  2. Klicken Sie auf den Namen der ThinApp-Anwendung.
  3. Klicken Sie auf die Registerkarte Computer, wählen Sie den Computer aus und klicken Sie auf Deinstallation erneut versuchen, um den Deinstallationsvorgang erneut auszuführen.
  4. Schlägt die Deinstallation erneut fehl, entfernen Sie die ThinApp-Anwendung manuell aus dem Computer und klicken Sie anschließend auf App-Status für Desktop entfernen.
    Über diesen Befehl wird die ThinApp-Anwendungszuweisung in Horizon Administrator gelöscht. Dateien oder Einstellungen im Computer werden nicht entfernt.
    Wichtig: Verwenden Sie diesen Befehl nur nach dem manuellen Entfernen der ThinApp-Anwendung aus dem Computer.