Die Verbindungsserver-Instanz oder der Sicherheitsserver, mit der bzw. dem die Smartcard verbunden ist, kann die Zertifikatsperrüberprüfung für das TLS-Zertifikat des Servers nur dann durchführen, wenn Sie die Smartcard-Zertifikatsperrüberprüfung konfiguriert haben.

Problem

Die Zertifikatsperrüberprüfung kann fehlschlagen, wenn Ihre Organisation für den Internetzugriff einen Proxy-Server verwendet oder wenn eine Verbindungsserver-Instanz oder ein Sicherheitsserver die Server, die die Sperrüberprüfung durchführen, aufgrund von Firewalls oder anderen Kontrollen nicht erreichen kann.

Wichtig: Stellen Sie sicher, dass die Zertifikatsperrlistendatei auf dem neuesten Stand ist.

Ursache

Horizon 7 unterstützt die Zertifikatssperrüberprüfung mit Zertifikatsperrlisten und dem Online Certificate Status Protocol (OCSP). Eine Zertifikatsperrliste ist eine Liste mit gesperrten Zertifikaten, die von der Zertifizierungsstelle veröffentlicht wird, die das Zertifikat ausgestellt hat. OCSP ist ein Zertifikatüberprüfungsprotokoll, das zum Abrufen des Sperrstatus eines X.509-Zertifikats verwendet wird. Der Zugriff auf die Zertifizierungsstelle muss über den Verbindungsserver- oder Sicherheitsserverhost möglich sein. Dieses Problem kann nur auftreten, wenn Sie die Zertifikatsperrüberprüfung für Smartcard-Zertifikate konfiguriert haben. Siehe Verwenden der Smartcard-Zertifikatsperrüberprüfung.

Lösung

  1. Erstellen Sie eine eigene (manuelle) Vorgehensweise für das Herunterladen einer aktuellen Zertifikatsperrliste von der Website der Zertifizierungsstelle in ein Verzeichnis auf Ihrem Horizon 7 Server.
  2. Erstellen oder bearbeiten Sie die Datei locked.properties im TLS/SSL-Gatewaykonfigurationsordner auf dem Verbindungsserver- oder Sicherheitsserver-Host.
    Beispiel: install_directory\VMware\VMware View\Server\SSLgateway\conf\locked.properties
  3. Fügen Sie die Eigenschaften enableRevocationChecking und crlLocation in der Datei locked.properties zum lokalen Verzeichnis hinzu, in dem die Zertifikatsperrliste gespeichert ist.
  4. Starten Sie den Verbindungsserver- oder Sicherheitsserverdienst neu, damit die Änderungen wirksam werden.